<font class="Apple-style-span" face="arial, helvetica, sans-serif">I've got a Studio 1557.  On Ubuntu 10.04 running kernel 2.6.32, eject, the backlight key, and the battery key all work fine.  There is a regression on Ubuntu 10.10 with kernel 2.6.34 and kernel 2.6.35; they do not work because of changes to /drivers/platform/x86/dell-wmi.c.  There is a patch for kernel 2.6.36, and this patch also works on 2.6.34 and 2.6.35.  I have tested the patch on gentoo-sources 2.6.34 and 2.6.35, as well as the Ubuntu kernel sources for 2.6.35 found in Maverick.</font><div>
<font class="Apple-style-span" face="arial, helvetica, sans-serif"><br></font></div><div><a href="http://www.gossamer-threads.com/lists/linux/kernel/1242512"><font class="Apple-style-span" face="arial, helvetica, sans-serif">http://www.gossamer-threads.com/lists/linux/kernel/1242512</font></a><font class="Apple-style-span" face="arial, helvetica, sans-serif"> shows the patch and</font></div>
<meta http-equiv="content-type" content="text/html; charset=utf-8"><div><a href="http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff_plain;h=d5164dbf1f651d1e955b158fb70a9c844cc91cd1"><font class="Apple-style-span" face="arial, helvetica, sans-serif">http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff_plain;h=d5164dbf1f651d1e955b158fb70a9c844cc91cd1</font></a><font class="Apple-style-span" face="arial, helvetica, sans-serif"> shows the actual commit for 2.6.36.  For some reason it hasn't been backported into 2.6.34 or 2.6.35.</font></div>
<div><font class="Apple-style-span" face="arial, helvetica, sans-serif"><br></font></div><div><a href="https://bugs.launchpad.net/ubuntu/+source/linux/+bug/609234"><font class="Apple-style-span" face="arial, helvetica, sans-serif">https://bugs.launchpad.net/ubuntu/+source/linux/+bug/609234</font></a><font class="Apple-style-span" face="arial, helvetica, sans-serif"> Relevant bug on launchpad.</font></div>
<div><font class="Apple-style-span" face="arial, helvetica, sans-serif"><br></font></div><div><font class="Apple-style-span" face="arial, helvetica, sans-serif">I'm new to the mailing list, so please let me know if I'm missing something or need to do more work to get this bug fixed.</font></div>
<div><font class="Apple-style-span" face="arial, helvetica, sans-serif"><br></font></div><div><font class="Apple-style-span" face="arial, helvetica, sans-serif"><br></font></div><div><font class="Apple-style-span" face="arial, helvetica, sans-serif"><br>
</font></div><div><font class="Apple-style-span" face="arial, helvetica, sans-serif">--Mark</font></div><meta http-equiv="content-type" content="text/html; charset=utf-8">