<div>Hi Andy,</div>
<div> </div>
<div><font color="#6600cc">There is no udev configuration included in the kernel package so that<br>sounds unlikely as a cause.  Where did your manually installed kernel<br>install to?  If it wrote over the stock one you may be able to recover<br>
by apt-get --reinstall linux-image-2.6.24-26.<br></font></div>
<div><font color="#000000">oh ok, thanks for the info, I was not aware that udev was not part of the kernel package.</font></div>
<div>I am not aware of the location where my manually installed kernel installed to. <font color="#009900">Please let me know how to find the location of the newly installed kernel.</font></div>
<div>My kernel sources are in /src/linux/linux-2.6.24 directory, in case if that was what you were asking.</div>
<div>I installed and updated GRUB using the <strong>make-kpkg</strong> command in ubuntu.</div>
<div><font color="#6600cc"></font> </div>
<div><font color="#6600cc">I routinly install multiple testing kernels without issues on my<br>systems, so you shouldn't need to make separate directories for this.</font></div>
<div> </div>
<div>ok, great, so what do you suggest I do?</div>
<div> </div>
<div>Thanks and Regs,</div>
<div>Praseen</div>
<div><br> </div>
<div class="gmail_quote">On 18 February 2010 18:46, Andy Whitcroft <span dir="ltr"><<a href="mailto:apw@canonical.com" target="_blank">apw@canonical.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="PADDING-LEFT: 1ex; MARGIN: 0px 0px 0px 0.8ex; BORDER-LEFT: #ccc 1px solid">
<div>On Thu, Feb 18, 2010 at 06:08:23PM +0530, Praseen Preman wrote:<br><br>> The issue I was facing was that, my nVidia drivers and<br>> creative sound card drivers failed to work at first for the 2.6.24<br>> version kernel and soon for the shipped 2.6.24-26 kernel too it failed<br>
> to work. Following this X windows too ceased to work properly for both<br>> the kernels.<br>><br>> What  isthe best way to solve and avoid such a scenario.<br>> I have a hunch that the since both the compiled 2.6.24 kernel and the<br>
> shipped 2.6.24-26 kernel used the same file system when they load ,the<br>> 2.6.24 kernel corrupted the udev configuration when it loaded and this<br>> corrupted udev created problems for the 2.6.24-26 kernel when it loaded<br>
> too. Please let me know the right approach to such a scenario and how<br>> to solve it.<br><br></div>There is no udev configuration included in the kernel package so that<br>sounds unlikely as a cause.  Where did your manually installed kernel<br>
install to?  If it wrote over the stock one you may be able to recover<br>by apt-get --reinstall linux-image-2.6.24-26.<br>
<div><br>> Does creating seperate ext3 filesystems for the multiple versions of the<br>> kernel<br>> help solve this issue? What is the suggested system configuration for<br>> kernel/ driver developers.<br><br>
</div>I routinly install multiple testing kernels without issues on my<br>systems, so you shouldn't need to make separate directories for this.<br><br>-apw<br></blockquote></div><br>