NAK/Cmnt: [PATCH][kinetic:linux-azure] PCI: hv: Fix the definition of vector in hv_compose_msi_msg()
Cory Todd
cory.todd at canonical.com
Fri Nov 18 16:10:35 UTC 2022
On Wed, Nov 09, 2022 at 04:26:00PM -0700, Tim Gardner wrote:
> From: Dexuan Cui <decui at microsoft.com>
>
> BugLink: https://bugs.launchpad.net/bugs/1996117
>
> The local variable 'vector' must be u32 rather than u8: see the
> struct hv_msi_desc3.
>
> 'vector_count' should be u16 rather than u8: see struct hv_msi_desc,
> hv_msi_desc2 and hv_msi_desc3.
>
> Fixes: a2bad844a67b ("PCI: hv: Fix interrupt mapping for multi-MSI")
> Signed-off-by: Dexuan Cui <decui at microsoft.com>
> Cc: Jeffrey Hugo <quic_jhugo at quicinc.com>
> Cc: Carl Vanderlip <quic_carlv at quicinc.com>
> Reviewed-by: Jeffrey Hugo <quic_jhugo at quicinc.com>
> Link: https://lore.kernel.org/r/20221027205256.17678-1-decui@microsoft.com
> Signed-off-by: Wei Liu <wei.liu at kernel.org>
> (backported from commit e70af8d040d2b7904dca93d942ba23fb722e21b1 linux-next)
> [rtg - context adjustments]
> Signed-off-by: Tim Gardner <tim.gardner at canonical.com>
> ---
> drivers/pci/controller/pci-hyperv.c | 22 ++++++++++++++++------
> 1 file changed, 16 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/pci/controller/pci-hyperv.c b/drivers/pci/controller/pci-hyperv.c
> index c10548243d65..49fa882aea1c 100644
> --- a/drivers/pci/controller/pci-hyperv.c
> +++ b/drivers/pci/controller/pci-hyperv.c
> @@ -1614,7 +1614,7 @@ static void hv_pci_compose_compl(void *context, struct pci_response *resp,
>
> static u32 hv_compose_msi_req_v1(
> struct pci_create_interrupt *int_pkt,
> - u32 slot, u8 vector, u8 vector_count)
> + u32 slot, u8 vector, u16 vector_count)
> {
> int_pkt->message_type.type = PCI_CREATE_INTERRUPT_MESSAGE;
> int_pkt->wslot.slot = slot;
> @@ -1666,7 +1666,7 @@ static int hv_compose_multi_msi_req_get_cpu(void)
>
> static u32 hv_compose_msi_req_v2(
> struct pci_create_interrupt2 *int_pkt, int cpu,
> - u32 slot, u8 vector, u8 vector_count)
> + u32 slot, u8 vector, u16 vector_count)
> {
> int_pkt->message_type.type = PCI_CREATE_INTERRUPT_MESSAGE2;
> int_pkt->wslot.slot = slot;
> @@ -1682,7 +1682,7 @@ static u32 hv_compose_msi_req_v2(
>
> static u32 hv_compose_msi_req_v3(
> struct pci_create_interrupt3 *int_pkt, int cpu,
> - u32 slot, u32 vector, u8 vector_count)
> + u32 slot, u32 vector, u16 vector_count)
> {
> int_pkt->message_type.type = PCI_CREATE_INTERRUPT_MESSAGE3;
> int_pkt->wslot.slot = slot;
> @@ -1719,7 +1719,12 @@ static void hv_compose_msi_msg(struct irq_data *data, struct msi_msg *msg)
> struct compose_comp_ctxt comp;
> struct tran_int_desc *int_desc;
> struct msi_desc *msi_desc;
> - u8 vector, vector_count;
> + /*
> + * vector_count should be u16: see hv_msi_desc, hv_msi_desc2
> + * and hv_msi_desc3. vector must be u32: see hv_msi_desc3.
> + */
> + u16 vector_count;
> + u32 vector;
> struct {
> struct pci_packet pci_pkt;
> union {
> @@ -1799,6 +1804,11 @@ static void hv_compose_msi_msg(struct irq_data *data, struct msi_msg *msg)
> cpu = hv_compose_msi_req_get_cpu(dest);
> }
>
> + /*
> + * hv_compose_msi_req_v1 and v2 are for x86 only, meaning 'vector'
> + * can't exceed u8. Cast 'vector' down to u8 for v1/v2 explicitly
> + * for better readability.
> + */
> memset(&ctxt, 0, sizeof(ctxt));
> init_completion(&comp.comp_pkt.host_event);
> ctxt.pci_pkt.completion_func = hv_pci_compose_compl;
> @@ -1808,7 +1818,7 @@ static void hv_compose_msi_msg(struct irq_data *data, struct msi_msg *msg)
> case PCI_PROTOCOL_VERSION_1_1:
> size = hv_compose_msi_req_v1(&ctxt.int_pkts.v1,
> hpdev->desc.win_slot.slot,
> - vector,
> + (u8)vector,
> vector_count);
> break;
>
> @@ -1817,7 +1827,7 @@ static void hv_compose_msi_msg(struct irq_data *data, struct msi_msg *msg)
> size = hv_compose_msi_req_v2(&ctxt.int_pkts.v2,
> cpu,
> hpdev->desc.win_slot.slot,
> - vector,
> + (u8)vector,
> vector_count);
> break;
>
Jammy was fine but Kinetic does not apply.
PCI: hv: Only reuse existing IRTE allocation for Multi-MSI
is problematic on Kinetic.
- corytodd
More information about the kernel-team
mailing list