where can I get the linux-tools-5.18.2 or how to build linux-tools on ubuntu22.04 with kernel 5.18.2

Juerg Haefliger juerg.haefliger at canonical.com
Tue Jun 28 12:39:21 UTC 2022


Please keep the list in the loop.

...Juerg


> hi @Juerg Haefliger <juerg.haefliger at canonical.com>
> after I built the
> file linux-tools-5.18.2-051802-generic_5.18.2-051802.202206060740_amd64.deb,
> I find that
> 1. the deb file is very small , only 2.1KB
> 2. the files data.tar.zst in the deb contains the linux-tools files, but
> they are all soft link files , and there is no file in
> ../../linux-tools-5.18.2-051802
> [image: image.png]
> 3. the control.tar.zst file contains a file named control, the conten shows
> that the deb file I built depends on linux-tools-5.18.2-051802
> 
> 
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> > *Package: linux-tools-5.18.2-051802-genericSource: linuxVersion:
> > 5.18.2-051802.202206060740Architecture: amd64Maintainer: Ubuntu Kernel Team
> > <kernel-team at lists.ubuntu.com
> > <kernel-team at lists.ubuntu.com>>Installed-Size: 21Depends:
> > linux-tools-5.18.2-051802Section: develPriority: optionalDescription: Linux
> > kernel version specific tools for version 5.18.2-051802 This package
> > provides the architecture dependant parts for kernel version locked tools
> > (such as perf and x86_energy_perf_policy) for version 5.18.2-051802 on 64
> > bit x86.*  
> 
> 
> 
> My Linux kernel version is Linux dh-pc 5.18.2-051802-generic #202206060740
> SMP PREEMPT_DYNAMIC Mon Jun 6 07:46:45 UTC 2022 x86_64 x86_64 x86_64
> GNU/Linux (download from here
> <https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.18.2/> )
> and ubuntu version is 22.04
> 
> Could you help me investigate why it depends on itself and where to find
> ../../linux-tools-5.18.2-051802 ?
> 
> Three Zhang <dhairoot at gmail.com> 于2022年6月25日周六 14:11写道:
> 
> > Thanks, I'll check it out.
> >
> > Juerg Haefliger <juerg.haefliger at canonical.com> 于2022年6月21日周二 19:51写道:
> >  
> >> On Fri, 17 Jun 2022 21:27:12 +0800
> >> Three Zhang <dhairoot at gmail.com> wrote:
> >>  
> >> > hi guys,
> >> >
> >> > My ubuntu version is 22.04 .
> >> > I download the new version of kernel which is  5.18.2 for my intel i7  
> >> 12700  
> >> > from here https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.18.2/
> >> > <https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.18.2/> .
> >> > But there is no matched linux-tools package in ubuntu repository.
> >> > So I would like to build linux-tools package from source .
> >> > Firstly , I clone the source code from here  git://
> >> >  
> >> git.launchpad.net/~ubuntu-kernel-test/ubuntu/+source/linux/+git/mainline-crack  
> >> > cod/mainline/v5.18.2 .
> >> > What should I do next ?  
> >>
> >> You need to rebuild the packages:
> >>
> >> $ git clone
> >> git.launchpad.net/~ubuntu-kernel-test/ubuntu/+source/linux/+git/mainline-crack
> >> $ cd mainline-crack
> >> $ git checkout cod/mainline/v5.18.2
> >> $ fakeroot debian/rules clean
> >> $ dpkg-checkbuilddeps
> >> $ fakeroot debian/rules do_linux_tools=true binary-generic
> >>
> >> This will build the kernel and modules and tools so will take quite a bit
> >> of time.
> >>
> >>  
> >> > Or is there any repositories that contain linux-tools-5.18.2 package ?  
> >>
> >> No. We do not auto-build that package for mainline kernels.
> >>
> >> ...Juerg
> >>
> >>  
> >> > Thanks  
> >>
> >>  

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <https://lists.ubuntu.com/archives/kernel-team/attachments/20220628/40ce3a71/attachment.sig>


More information about the kernel-team mailing list