[PATCH V2 3/5 G][L-R-M] UBUNTU: [packaging] drop nvidia-kernel-common dependency from the ABI metas

Alberto Milone alberto.milone at canonical.com
Mon Jul 20 14:32:52 UTC 2020


This drops the dependency on nvidia-kernel-common from the ABI meta
packages, since the dependency is already expressed by the main meta
packages.

BugLink: https://bugs.launchpad.net/bugs/1881137
Signed-off-by: Alberto Milone <alberto.milone at canonical.com>
---
 debian/control.d/nvidia | 6 ------
 1 file changed, 6 deletions(-)

diff --git a/debian/control.d/nvidia b/debian/control.d/nvidia
index c99ab02..7284bfb 100644
--- a/debian/control.d/nvidia
+++ b/debian/control.d/nvidia
@@ -9,7 +9,6 @@ Depends:
  ${shlibs:Depends},
  binutils,
  linux-image- at ABI@-generic | linux-image-unsigned- at ABI@-generic,
- nvidia-kernel-common-390,
 Description: Linux kernel nvidia modules for version @ABI@
  This package contains the Linux kernel nvidia modules for version @ABI at .
  .
@@ -29,7 +28,6 @@ Depends:
  ${shlibs:Depends},
  binutils,
  linux-image- at ABI@-generic | linux-image-unsigned- at ABI@-generic,
- nvidia-kernel-common-435,
 Description: Linux kernel nvidia modules for version @ABI@
  This package contains the Linux kernel nvidia modules for version @ABI at .
  .
@@ -49,7 +47,6 @@ Depends:
  ${shlibs:Depends},
  binutils,
  linux-image- at ABI@-generic | linux-image-unsigned- at ABI@-generic,
- nvidia-kernel-common-440,
 Description: Linux kernel nvidia modules for version @ABI@
  This package contains the Linux kernel nvidia modules for version @ABI at .
  .
@@ -69,7 +66,6 @@ Depends:
  ${shlibs:Depends},
  binutils,
  linux-image- at ABI@-lowlatency | linux-image-unsigned- at ABI@-lowlatency,
- nvidia-kernel-common-390,
 Description: Linux kernel nvidia modules for version @ABI@
  This package contains the Linux kernel nvidia modules for version @ABI at .
  .
@@ -89,7 +85,6 @@ Depends:
  ${shlibs:Depends},
  binutils,
  linux-image- at ABI@-lowlatency | linux-image-unsigned- at ABI@-lowlatency,
- nvidia-kernel-common-435,
 Description: Linux kernel nvidia modules for version @ABI@
  This package contains the Linux kernel nvidia modules for version @ABI at .
  .
@@ -109,7 +104,6 @@ Depends:
  ${shlibs:Depends},
  binutils,
  linux-image- at ABI@-lowlatency | linux-image-unsigned- at ABI@-lowlatency,
- nvidia-kernel-common-440,
 Description: Linux kernel nvidia modules for version @ABI@
  This package contains the Linux kernel nvidia modules for version @ABI at .
  .
-- 
2.25.1




More information about the kernel-team mailing list