ACK: [PATCH v2 0/2][SRU][B/F/OEM-B/OEM-OSP1-B/OEM-5.6] Fix System stops responding while entering S3 with SD card installed

Juerg Haefliger juerg.haefliger at canonical.com
Wed Jul 15 07:32:04 UTC 2020


Acked-by: Juerg Haefliger <juergh at canonical.com>


> BugLink: https://bugs.launchpad.net/bugs/1880519
> 
> [Impact]
> The system stops responding while entering S3, screen will be lit up
> if touchpad is triggered by finger. Cursor could be seen with black background,
> but system is not responding to any input.
> 
> [Fix]
> Patchset[1] for fix this issue currently landed in upstream,
> so we backported them:
> 
> [1]:
> b3d71abd135e xhci: Poll for U0 after disabling USB2 LPM
> f0c472a6da51 xhci: Return if xHCI doesn't support LPM
> 
> [Test]
> With the above patch applied, run:
> sudo fwts --s3-sleep-delay=30 --s3-multiple=30 -p s3
> 
> Can passed 30 times.
> 
> [Regression Potential]
> Low, the patch is just like a safeguard,
> doesn't really change any behavior.
> 
> v2: Fix the wrong email subject.
> 
> Kai-Heng Feng (2):
>   xhci: Return if xHCI doesn't support LPM
>   xhci: Poll for U0 after disabling USB2 LPM
> 
>  drivers/usb/host/xhci.c | 8 +++++++-
>  1 file changed, 7 insertions(+), 1 deletion(-)
> 

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <https://lists.ubuntu.com/archives/kernel-team/attachments/20200715/2dc86f7f/attachment.sig>


More information about the kernel-team mailing list