ACK: [SRU][Focal][PULL] update ENA driver for LLQ

Khaled Elmously khalid.elmously at canonical.com
Sun Aug 16 01:37:05 UTC 2020


Acked-by: Khalid Elmously <khalid.elmously at canonical.com>


On 2020-08-07 13:25:43 , Kamal Mostafa wrote:
> BugLink: https://bugs.launchpad.net/bugs/1890845
> 
> This pull request update the Amazon ENA driver in focal-generic with all
> upstream commits from mainline and net-next, through:
> 
>   0e3a3f6dacf0 net: ena: support new LLQ acceleration mode
> 
> The commits are all cherry-picks or light context backports; touches only the
> ENA driver.
> 
> The driver update provides new hardware support, fixes, and features required
> to support future ENA devices at AWS.
> 
> I have smoke-tested the build; no problems noted.
> 
>  -Kamal
> 
> -----
> 
> The following changes since commit 9416868088c864ace64acae00fa42f4d3c687404:
> 
>   UBUNTU: upstream stable to v5.4.54 (2020-07-30 16:27:08 -0600)
> 
> are available in the Git repository at:
> 
>   git://git.launchpad.net/~kamalmostafa/ubuntu/+source/linux/+git/focal ena-update
> 
> for you to fetch changes up to 2e6e4b15854114b4409eb480565ec91850c54435:
> 
>   net: ena: support new LLQ acceleration mode (2020-08-07 12:58:57 -0700)
> 
> ----------------------------------------------------------------
> Arthur Kiyanovski (31):
>       net: ena: fix default tx interrupt moderation interval
>       net: ena: fix broken interface between ENA driver and FW
>       net: ena: fix incorrect setting of the number of msix vectors
>       net: ena: fix request of incorrect number of IRQ vectors
>       net: ena: avoid memory access violation by validating req_id properly
>       net: ena: fix continuous keep-alive resets
>       net: ena: avoid unnecessary admin command when RSS function set fails
>       net: ena: change default RSS hash function to Toeplitz
>       net: ena: drop superfluous prototype
>       net: ena: cosmetic: extract code to ena_indirection_table_set()
>       net: ena: add support for the rx offset feature
>       net: ena: rename ena_com_free_desc to make API more uniform
>       net: ena: use explicit variable size for clarity
>       net: ena: fix ena_com_comp_status_to_errno() return value
>       net: ena: simplify ena_com_update_intr_delay_resolution()
>       net: ena: cosmetic: set queue sizes to u32 for consistency
>       net: ena: cosmetic: fix spelling and grammar mistakes in comments
>       net: ena: cosmetic: fix line break issues
>       net: ena: cosmetic: remove unnecessary code
>       net: ena: cosmetic: code reorderings
>       net: ena: cosmetic: fix spacing issues
>       net: ena: cosmetic: minor code changes
>       net: ena: reduce driver load time
>       net: ena: avoid unnecessary rearming of interrupt vector when busy-polling
>       net: ena: add reserved PCI device ID
>       net: ena: cosmetic: satisfy gcc warning
>       net: ena: cosmetic: change ena_com_stats_admin stats to u64
>       net: ena: add support for traffic mirroring
>       net: ena: enable support of rss hash key and function changes
>       net: ena: move llq configuration from ena_probe to ena_device_init()
>       net: ena: support new LLQ acceleration mode
> 
> Colin Ian King (2):
>       net: ena: ethtool: remove redundant non-zero check on rc
>       net: ena: ethtool: clean up minor indentation issue
> 
> Leon Romanovsky (1):
>       net/amazon: Ensure that driver version is aligned to the linux kernel
> 
> Sameeh Jubran (18):
>       net: ena: change num_queues to num_io_queues for clarity and consistency
>       net: ena: multiple queue creation related cleanups
>       net: ena: ethtool: get_channels: use combined only
>       net: ena: make ethtool -l show correct max number of queues
>       net: ena: remove redundant print of number of queues
>       net: ena: ethtool: support set_channels callback
>       net: ena: implement XDP drop support
>       net: ena: Implement XDP_TX action
>       net: ena: Add first_interrupt field to napi struct
>       net: ena: allow setting the hash function without changing the key
>       net: ena: changes to RSS hash key allocation
>       net: ena: remove code that does nothing
>       net: ena: add unmask interrupts statistics to ethtool
>       net: ena: add support for reporting of packet drops
>       net: ena: use SHUTDOWN as reset reason when closing interface
>       net: ena: cosmetic: remove unnecessary spaces and tabs in ena_com.h macros
>       net: ena: xdp: XDP_TX: fix memory leak
>       net: ena: xdp: update napi budget for DROP and ABORTED
> 
> Vaibhav Gupta (1):
>       ena_netdev: use generic power management
> 
> Wang Hai (1):
>       net: ena: Fix using plain integer as NULL pointer in ena_init_napi_in_range
> 
> YueHaibing (3):
>       net: ena: remove set but not used variable 'rx_ring'
>       net: ena: remove set but not used variable 'hash_key'
>       net: ena: Make some functions static
> 
>  drivers/net/ethernet/amazon/ena/ena_admin_defs.h  |   66 +-
>  drivers/net/ethernet/amazon/ena/ena_com.c         |  141 ++-
>  drivers/net/ethernet/amazon/ena/ena_com.h         |   93 +-
>  drivers/net/ethernet/amazon/ena/ena_common_defs.h |    2 +-
>  drivers/net/ethernet/amazon/ena/ena_eth_com.c     |   77 +-
>  drivers/net/ethernet/amazon/ena/ena_eth_com.h     |   10 +-
>  drivers/net/ethernet/amazon/ena/ena_eth_io_defs.h |    6 +-
>  drivers/net/ethernet/amazon/ena/ena_ethtool.c     |  109 +-
>  drivers/net/ethernet/amazon/ena/ena_netdev.c      | 1355 ++++++++++++++++-----
>  drivers/net/ethernet/amazon/ena/ena_netdev.h      |  108 +-
>  drivers/net/ethernet/amazon/ena/ena_pci_id_tbl.h  |    5 +
>  drivers/net/ethernet/amazon/ena/ena_regs_defs.h   |    2 +-
>  12 files changed, 1447 insertions(+), 527 deletions(-)
> 
> -- 
> kernel-team mailing list
> kernel-team at lists.ubuntu.com
> https://lists.ubuntu.com/mailman/listinfo/kernel-team



More information about the kernel-team mailing list