APPLIED: [PATCH 0/1][SRU][B] linux-firmware: Update firmware file for Intel Bluetooth 9560

Seth Forshee seth.forshee at canonical.com
Wed May 29 18:57:42 UTC 2019


On Tue, May 21, 2019 at 06:06:40PM +0800, You-Sheng Yang wrote:
> BugLink: https://bugs.launchpad.net/bugs/1829737
> 
> [Impact]
> The firmware blob for Intel Bluetooth 9560/9462 is versioned 20.30.0.1
> is not compatible with kernel version >= 4.19 and will cause failure to
> pair BT 4.0 devices.
> 
> [Fix]
> 29a536a02cad linux-firmware: Update firmware file for Intel Bluetooth 9560
> 
> Above upstream change contains latest firmware file for Intel Bluetooth
> 9560 that fixes HID pairing in recent kernel versions.
> 
> [Test Case]
> Copy ibt-17-16-1.sfi blob to /lib/firmware/intel and do a cold boot to
> reload firmware. One should find following message in dmesg:
> 
>   Bluetooth: hci0: Bootloader revision 0.1 build 42 week 52 2015
> 
> This indicates firmware reload has been activated. For further warm
> boots, kernel would dump updated revision:
> 
>   Bluetooth: hci0: Firmware revision 0.1 build 184 week 15 2019
> 
> And perform BT 4.0 device pairing for functional tests.
> 
> Tested blob against following kernel versions:
> * 5.0.0-1004-oem-osp1
> * 5.0.0-15-generic
> * 4.18.0-20-generic
> * 4.15.0-1038-oem
> * 4.15.0-50-generic
> 
> [Regression Risk]
> Low. This affects only Intel JeffersonPeak Bluetooth chip series, namely
> 9461/9462/9560, which are the hardware variants to be fixed.
> 
> [Misc]
> Affected linux-firmware package series:
> * Trusty: N/A
> * Xenial: REL0186
>   * 4.4.0-1480generic (not supported)
>   * 4.15.0-50-generic (not affected)
> * Bionic: REL0201 20.30.0.1
>   * 4.15.0-1038-oem (not affected)
>   * 4.15.0-50-generic (not affected)
>   * 4.18.0-20-generic (not affected)
>   * 5.0.0-1004-oem-osp1 (affected)
> * Cosmic: REL0329 20.70.0.4
>   * 4.15.0-50-generic (not affected)
>   * 4.18.0-20-generic (not affected)
> * Disco: REL0420 21.0.0.4
>   * 4.15.0-1038-oem (not affected)
>   * 5.0.0-15-generic (not affected)
> * Eoan: REL0420 21.0.0.4
>   * 4.15.0-1038-oem (not affected)
>   * 5.0.0-15-generic (not affected)
> 
> Only Bionic with 5.0.0-1004-oem-osp1 is affected.

Applied, thanks!



More information about the kernel-team mailing list