[SRU][Bionic/OEM-B][PATCH 0/1] USB cardreader (0bda:0328) make the system can't enter s3 or hang

Hui Wang hui.wang at canonical.com
Wed Oct 17 11:45:07 UTC 2018

BugLink: https://bugs.launchpad.net/bugs/1798328

This patch is already in the Cosmic.

The OEM project is waiting for this patch to be landed in the OEM-B kernel,
if it passes review, please help merge this patch to OEM-B kernel ASAP.

We have a couple o lenovo laptops, they have the realtek cardreader (0bda:0328),
this cardreader is the latest product from realtek, and it uses the common
usb-to-scsi driver UAS. When the system suspend and resume, the USB host will
print some errors like can't disable the device under this USB bus and
reset-and-verify fails, after that the system can't suspend anymore and hang

the mainline build v4.17-rc1 doesn't have this issue, so through bisecting,
we found this patch can fix the problem.

[Test Case]
suspend and resume 30 times, and plug sd storage card into the cardreader,
everything worked well.

[Regression Potential]
Low, we tested this patch on 7 different lenovo laptops. After suspending
and resuming for 30 times, the system still worked well, and plug a usb
storage, it still worked well.

Mathias Nyman (1):
  usb: Don't disable Latency tolerance Messaging (LTM) before port reset

 drivers/usb/core/hub.c | 13 +++----------
 1 file changed, 3 insertions(+), 10 deletions(-)


More information about the kernel-team mailing list