[PATCH][OEM][Artful][8086:3e92] display becomes blank after S3

AceLan Kao acelan.kao at canonical.com
Wed Mar 28 03:20:57 UTC 2018


BugLink: https://launchpad.net/bugs/1759188

[Impact]
The display becomes blank after S3 with the following error messages.

[ 38.304449] [drm:gmbus_xfer [i915]] GMBUS [i915 gmbus dpd] NAK for addr: 0050 w(1)
[ 38.304462] [drm:gmbus_xfer [i915]] GMBUS [i915 gmbus dpd] NAK on first message, retry
[ 38.306726] [drm:gmbus_xfer [i915]] GMBUS [i915 gmbus dpd] NAK for addr: 0050 w(1)
[ 38.306733] [drm:drm_do_probe_ddc_edid [drm]] drm: skipping non-existent adapter i915 gmbus dpd
[ 38.311251] [drm:drm_dp_dual_mode_detect [drm_kms_helper]] DP dual mode HDMI ID: DP-HDMI ADAPTOR\004 (err 0)
[ 38.313538] [drm:drm_dp_dual_mode_detect [drm_kms_helper]] DP dual mode adaptor ID: 44 (err 0)
[ 38.313554] [drm:intel_hdmi_set_edid [i915]] DP dual mode adaptor (type 1 HDMI) detected (max TMDS clock: 165000 kHz)
[ 38.313557] [drm:drm_helper_hpd_irq_event [drm_kms_helper]] [CONNECTOR:115:HDMI-A-1] status updated from disconnected to disconnected

[Fix]
This commit pointed out by Timo fixes the issue.

[Regression Potential]
Should be low, although the change applies broadly.
>From the patch description, it explains why it should be safe.
> This workaround was designed to minimize the impact only
> to save the bad case with that link rates. But HW engineers
> indicated that it should be safe to apply broadly, although
> they were expecting the DPLL0 link rate to be unchanged on
> runtime.

Lucas De Marchi (1):
  drm/i915: Apply Display WA #1183 on skl, kbl, and cfl

 drivers/gpu/drm/i915/i915_reg.h         |  2 ++
 drivers/gpu/drm/i915/intel_cdclk.c      | 35 ++++++++++++++++++++++++---------
 drivers/gpu/drm/i915/intel_runtime_pm.c | 10 ++++++++++
 3 files changed, 38 insertions(+), 9 deletions(-)

-- 
2.7.4





More information about the kernel-team mailing list