Patches related to Thinkpad 13 G2's Raydium touchscreen

Sejo Ruiz sejoruiz at gmail.com
Sun Sep 10 14:42:15 UTC 2017


Hi all.

I'm trying to get the touchscreen of my laptop (a Thinkpad 13 G2) to work with
Archlinux. I haven't had much luck until now, so I turned to see if I could make
it work with Ubuntu. It was a nice surprise to see that it worked out of the
box. So, now the big question is how can I make it work under Archlinux. Does
anybody know if there are any patches that are relevant to this? Am I missing
some configuration?

As far as I can tell, the touchscreen is listed under xinput --list:

xinput --list

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Raydium Touchscreen                       id=11   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech TrackPoint                id=13   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=14   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Integrated Camera                         id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                    id=15   [slave  keyboard (3)]

It also shows up as an input device:

less /proc/bus/input/devices

I: Bus=0018 Vendor=0000 Product=0000 Version=0000
N: Name="Raydium Touchscreen"
P: Phys=
S: Sysfs=/devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-6/i2c-RAYD0001:00/input/input10
U: Uniq=
H: Handlers=event8 mouse0
B: PROP=2
B: EV=b
B: KEY=400 0 0 0 0 0
B: ABS=661800001000003

And finally, the relevant dmesg line.

dmesg | grep -i ray

[    3.407314] input: Raydium Touchscreen as
/devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-6/i2c-RAYD0001:00/input/input10

Finally, I noticed that in the Ubuntu Live CD, the hid-multitouch module is
loaded automatically (which doesn't happen in archlinux). I have tried it to
modprobe it manually using the VENDOR, PRODUCT, BUS and MT_CLASS that appear in Ubuntu,
without luck. Furthermore, it seems like Archlinux can't read the VENDOR and
PRODUCT correctly.

So, I think I'm out of ideas and I'm hoping that one of you guys can lend me a
hand.

Thanks to all of you.

PS: If there is any other information that is needed to troubleshoot this, I'll
be happy to provide it.

-- 
Kind regards.

//Sergio




More information about the kernel-team mailing list