Bug#885529: trace-cmd: Build-Depends on unmaintained pygtk

Jeremy Bicha jbicha at debian.org
Wed Dec 27 17:08:45 UTC 2017


Source: trace-cmd
Version: 2.6.1-0.1
Severity: important
User: pkg-gnome-maintainers at lists.alioth.debian.org
Usertags: oldlibs pygtk
Tags: sid buster

pygtk is unmaintained upstream. It has not had a release since GNOME 3
was released in 2011.

The way forward is to port your app to use GObject Introspection
bindings (and gtk3).

For more information on GObject Introspection see [1] and [2].

Please try to do this before the Buster release as we're going to
try to remove pygtk this cycle.

If you have any question don't hesitate to ask.

[1] https://wiki.gnome.org/Projects/GObjectIntrospection
[2] https://wiki.gnome.org/Projects/PyGObject

On behalf of the Debian GNOME team,
Jeremy Bicha




More information about the kernel-team mailing list