[Xenial PATCH 0/3] audio driver couldn't work after S3 resume

Hui Wang hui.wang at canonical.com
Wed Jul 6 01:48:04 UTC 2016

This problem is reported by Intel side (lp:#1596871), they have
reproduced the problem on their side, and gave the solution for this
problem, the solution is to backport the 3 patches as shown below
to xenial kernel.

After applying the 3 patches to xenial kernel, I tested the kernel
on 2 Dell laptops (haswell and broadwell), 1 HP laptops (skylake),
two lenovo laptops (skylake and baytrail) and 1 Intel SDP (kabylake),
They all worked well, and both analog audio and hdmi audio worked well
before and after s3 resume.

The 3 patches are not needed for Yakkety kernel since those 3 patches
were merged in the upstream kernel linux-4.5, so the Yakkety already
has those patches.

Libin Yang (2):
  ALSA: hda - hdmi add wmb barrier for audio component
  ALSA: hda - hdmi defer to register acomp eld notifier

Takashi Iwai (1):
  ALSA: hda - Skip ELD notification during PM process

 sound/pci/hda/patch_hdmi.c | 22 +++++++++++++++-------
 1 file changed, 15 insertions(+), 7 deletions(-)


More information about the kernel-team mailing list