[Xenial kernel] Only one cpu is successfully detected.

wyang w90p710 at gmail.com
Wed Dec 7 09:55:45 UTC 2016


Hi team,,

I have a customer, who tried to install Xenial or upgrade to 4.4 kernel 
with Trusty on our cloud platform(qemu 1.5.3), reports a defect. he 
complains that only  one cpu is successfully detected, other cpus is 
disabled if
he used 4.4 kernel. I tried to bisect Xenial kernel tree, and found that 
this bug was introduced by the following commit.

commit 31c2013e4ea2e594522980acc3d20e88664b19f1
Author: Thomas Gleixner <tglx at linutronix.de>
Date:   Mon Feb 22 22:19:15 2016 +0000

     x86/topology: Create logical package id

     BugLink: http://bugs.launchpad.net/bugs/1397880

     For per package oriented services we must be able to rely on the 
number of CPU
     packages to be within bounds. Create a tracking facility, which

     - calculates the number of possible packages depending on 
nr_cpu_ids after boot

     - makes sure that the package id is within the number of possible 
packages. If
       the apic id is outside we map it to a logical package id if there 
is enough
       space available.

     Provide interfaces for drivers to query the mapping and do 
translations from
     physcial to logical ids.

and then I backported 7b0501b1e7cddd32b265178e32d332bdfbb532d4 from 
Linus tree to Xenial kernel, the issue goes away, so could we consider 
to backport it to xenial kernel tree to solve this issue in next release?

 From 7b0501b1e7cddd32b265178e32d332bdfbb532d4 Mon Sep 17 00:00:00 2001
From: Jiri Olsa <jolsa at redhat.com>
Date: Mon, 15 Aug 2016 12:17:00 +0200
Subject: [PATCH] x86/smp: Fix __max_logical_packages value setup

Frank reported kernel panic when he disabled several cores in BIOS
via following option:

Thanks
Wei




More information about the kernel-team mailing list