[Acked/cmt] [Vivid][PULL]: ubuntu/i915 backport driver for Skylake & Cherryview
Andy Whitcroft
apw at canonical.com
Fri Mar 27 11:19:08 UTC 2015
On Wed, Mar 11, 2015 at 06:46:33PM +0200, Timo Aaltonen wrote:
>
> Hi
>
> Soo, here's the first take on providing a backport driver for SKL/CHV currently based on drm-intel-next-2015-02-27 tag, ie. code that's going to end up in 4.1. The plan has recently changed to support Cherryview (=Braswell) too so the driver module is named 'i915_bpo' ('backport', as used in Debian), still easy to change though so feel free to bikeshed :).
>
> git://kernel.ubuntu.com/tjaalton/ubuntu-trusty.git i915-bpo
ubuntu-vivid.git ...
Uggg.
New driver:
2aa2c27 UBUNTU: SAUCE: i915_bpo: Provide a backport driver for Skylake & Cherryview graphics
3559ad8 UBUNTU: SAUCE: i915_bpo: Update intel_ips.h file location
1c95ca5 UBUNTU: SAUCE: i915_bpo: Only support Skylake and Cherryview with the backport driver
920d48e UBUNTU: SAUCE: i915_bpo: Rename the backport driver to i915_bpo
0cb0d32 UBUNTU: i915_bpo: [Config] Enable CONFIG_DRM_I915_BPO=m
d57ab67 UBUNTU: SAUCE: i915_bpo: Add i915_bpo_*() calls for ubuntu/i915
d44475d UBUNTU: SAUCE: i915_bpo: Revert "drm/i915: remove unused power_well/get_cdclk_freq api"
dd1023a UBUNTU: SAUCE: i915_bpo: Add i915_bpo specific power well calls
The new driver -- only basically only affects ubuntu/i915/*
Core changes:
9d107be drm/i915/skl: Split the SKL PCI ids by GT
cherrypick
essentially a noop splitting ids and recombining them
2d454c0 drm: Reorganize probed mode validation
cherrypick
essentially a noop does reorder how things are done
606614c drm: Perform basic sanity checks on probed modes
cherrypick
extra validation of modes
335a1ae drm: Do basic sanity checks for user modes
cherrypick
extra validation of modes
30acecd drm/atomic-helper: Export both plane and modeset check helpers
cherrypick
exports some checks for reuse
035b6b0 drm/atomic-helper: Again check modeset *before* plane states
cherrypick
basically a revert and a bugfix
bab525f drm/atomic: Introduce state->obj backpointers
cherrypick
extra structure linkage
04f1770 drm: allow property validation for refcnted props
cherrypick
interface cleanup
dc7ae83 drm: store property instead of id in obj attachment
cherrypick
follow above interface change
8644fc6 drm: get rid of direct property value access
cherrypick
follow above interface change
f1e8b2e drm: add atomic_set_property wrappers
cherrypick
interface cleanup
9ed85c2 drm: tweak getconnector locking
cherrypick
locking fix
a77ad41 drm: add atomic_get_property
cherrypick
interface cleanup
c92910b drm: Remove unneeded braces for single statement blocks
cherrypick
style cleanup
f26bbb5 drm: refactor getproperties/getconnector
cherrypick
commonises some duplicated code
ac7cee1 drm: add atomic properties
cherrypick
introduces the atomic properties interfaces that the bpo driver needs
b81136b drm/atomic: atomic_check functions
cherrypick
additional validation
c793a3e drm: small property creation cleanup
cherrypick
code cleanup
3946385 drm/atomic: atomic plane properties
cherrypick
new properties of the drm objects when in atomic mode
9a86234 drm/atomic: atomic connector properties
cherrypick
new properties of the drm objects when in atomic mode
c443384 drm: Atomic modeset ioctl
cherrypick
adds the new atomic modeset interface itself
2f18fab drm/atomic: Hide drm.ko internal interfaces
cherrypick
pulls some code private again
46c2fe8 drm: Ensure universal_planes is set for atomic
cherrypick
atomic related cleanup
e006241 drm: fix mismerge in drm_crtc.c
cherrypick
ooops
22a03e6 drm: bit of spell-check / editorializing.
cherrypick
text changes only
dbdb17d drm: add support for tiled/compressed/etc modifier in addfb2
cherrypick
infrastructure for per fb formats
db45c4a drm: Add rotation value to plane state
cherrypick
exposes rotation
79039679 drm: add helper to get crtc timings (v5)
cherrypick
new helper
688e1b2 drm: Adding edp1.4 specific dpcd macros
cherrypick
new macros
cc28e38 drm/plane-helper: Skip prepare_fb/cleanup_fb when newfb==oldfb
cherrypick
optimisation
1b27bc8 UBUNTU: SAUCE: Backport I915_PARAM_MMAP_VERSION and I915_MMAP_WC
ab91958 UBUNTU: SAUCE: Partial backport of drm/i915: Add ioctl to set per-context parameters
93c6570 UBUNTU: SAUCE: drm/i915: Specify bsd rings through exec flag
105d273 UBUNTU: SAUCE: drm/i915: add I915_PARAM_HAS_BSD2 to i915_getparam
7dae6ea UBUNTU: SAUCE: drm/i915: add component support
7622750 UBUNTU: SAUCE: drm/i915: Add tiled framebuffer modifiers
102cb8b UBUNTU: SAUCE: Backport new displayable tiling formats
b465a8c UBUNTU: SAUCE: Backport drm_crtc_vblank_reset() helper
aed494f UBUNTU: SAUCE: drm/i915: Add I915_PARAM_REVISION
5b15fd1 UBUNTU: SAUCE: drm/i915: Export total subslice and EU counts
99ee1ea UBUNTU: SAUCE: i915_bpo: Revert drm/mm: Support 4 GiB and larger ranges
all partial backports of new features for ubuntu/i915
Ok, assuming that all of these cherrypicks are needed, and that is hard
to be cirtain of without dropping them and seeing, the overall plan
seems consistant. The majority of this looks benign where it affects
existing platforms but there is some right and so some proper testing on
a range of i915 platforms particularly _old_ ones is going to be needed
to have any confidence.
Also this is going to make the lives of the stable team hard, so to them
I can only applogise. I think on balance that support for this kit in
Vivid is going to be necessary, and so this is probabally unavoidable.
Not Happy (tm).
Grudgingly:
Acked-by: Andy Whitcroft <apw at canonical.com>
-apw
More information about the kernel-team
mailing list