Cleaning up Xen OSXSAVE hacks on previous releases

Stefan Bader stefan.bader at canonical.com
Fri Sep 21 15:28:00 UTC 2012


Following up with the various releases. Since only kernel
versions between 2.6.30 and 2.6.39 require any hack this
reverts the new work-around from Precise, the old hack
from Oneiric and pulls in the upstream change that always
masks both xsave bits from cpuid. The second Lucid patch
optionally picks the upstream change that would allow to
use xsave when the HV supports it (this time it seemed to
be the correct way to check).

There is not anything to revert on Lucid master but it would
be one step further to be able to get away from the need for
the ec2 topic branch carrying all those special Xen patches.

-Stefan




More information about the kernel-team mailing list