[PATCH] compat: add compat kernel checker and downloader

Luis R. Rodriguez mcgrof at frijolero.org
Sat Mar 31 00:23:46 UTC 2012


Andy, so I just noticed that on all Ubuntu PPA (and generic) kernels
you guys have a broken symlink >= 2.6.33.

/lib/modules/2.6.33-02063305-generic/build/include/asm

points to asm-x86 and that is no longer present after 2.6.33 so any
module requiring those header files will break now on Ubuntu. I just
spotted this as some file from asm is now included in the modules were
are building. I guess not many external kernel modules include asm dir
otherwise you guys would have noticed this a long time ago.

  Luis




More information about the kernel-team mailing list