Booting ancient kernels on Ubuntu 9.10

Stefan Bader stefan.bader at
Mon Jan 18 15:01:37 UTC 2010

Luis R. Rodriguez wrote:
> On Fri, Jan 15, 2010 at 10:28 AM, Luis R. Rodriguez <mcgrof at> wrote:
>> Curious if other developers have tried to boot ancient kernels on
>> Ubuntu 9.10. I've had issues, seems init fails while trying to mount
>> the root filesystem but I'm not yet sure why that is. I tried 2.6.23
>> and 2.6.24 but no luck. I have the other kernels, will see at which
>> one it started to fail, but curious if others have tried.
> I've tested 2.6.23 all the way up and the last working kernel is
> 2.6.27. Here's a picture of 2.6.25 boot failure, but its the same on
> 2.6.26:
> I'm using stock kernel builds for >= 2.6.27 as that is when Ubuntu
> started producing mainline kernels, I've built the others which makes
> me suspect I misconfigured them. Here's my config on 2.6.26, for
> example:
> Not sure what it could be.
>   Luis
Not really sure what it might be in that case. Often its changes in either udev
messages or sysfs layout. The first message on the screen sounds a bit likes
some path in sysfs is not found. Though it might be a follow up.
A problem between 2.6.24 and later could be that sysfs changed some entries to
be links instead of directories and at least lvm2 had its troubles with that
going the other way round (using a newer kernel on an older system).
Does your boot get up enough to get a busybox shell to play around with?


More information about the kernel-team mailing list