Booting ancient kernels on Ubuntu 9.10

Luis R. Rodriguez mcgrof at
Fri Jan 15 18:54:57 UTC 2010

On Fri, Jan 15, 2010 at 10:50 AM, Luis R. Rodriguez <mcgrof at> wrote:
> On Fri, Jan 15, 2010 at 10:28 AM, Luis R. Rodriguez <mcgrof at> wrote:
>> Curious if other developers have tried to boot ancient kernels on
>> Ubuntu 9.10. I've had issues, seems init fails while trying to mount
>> the root filesystem but I'm not yet sure why that is. I tried 2.6.23
>> and 2.6.24 but no luck. I have the other kernels, will see at which
>> one it started to fail, but curious if others have tried.
> I've tested 2.6.23 all the way up and the last working kernel is
> 2.6.27. Here's a picture of 2.6.25 boot failure, but its the same on
> 2.6.26:
> I'm using stock kernel builds for >= 2.6.27 as that is when Ubuntu
> started producing mainline kernels, I've built the others which makes
> me suspect I misconfigured them. Here's my config on 2.6.26, for
> example:
> Not sure what it could be.

Does upstart 0.6.3-11 depend on stuff only in newer kernels?


More information about the kernel-team mailing list