Lost monitor at boot (was Re: [ubuntu-x] Nouveau - remaining tasks.)

Bryce Harrington bryce at canonical.com
Tue Feb 23 18:39:47 UTC 2010


On Mon, Feb 22, 2010 at 01:38:37PM +1100, Christopher James Halse Rogers wrote:
> Finally, I'm still seeing some reports on IRC of nouveau turning off the
> monitor on boot, leaving the system unusable.  I've done some
> investigation, and I've got a hypothesis: if vga16fb gets loaded first,
> it claims fb0 and everything dies a fiery death.  

Are you able to reproduce this issue?  Is there a bug# for tracking?  If
not, let's get a bug report in about it filed against
linux-backports-modules.

Also, why would this fail for some people but not others?  It seems like
something which should always work or always fail.

> From my slight understanding of modules.order, the in-kernel gpu drivers
> won't suffer from this because they're listed before vga16fb.  Testing
> this by editing modules.order to place i915 after vga16fb results in my
> intel laptop displaying similar symptoms.  I'm not familiar with how the
> kernel uses modules.order, though, so this could be wrong.  It suggests
> that we may have the same sort of problems should we pull 2.6.34 drm
> into lbm for intel & radeon, though.

Well, assuming the kernel team does go forward with the drm full
backport of .33 the immediate issue goes away at least.

Is the solution as simple as just making sure l-b-m loads its drm
modules prior to vga16fb?  If so, could whatever adds this line simply
be made to insert it in the line prior to vga16fb?

Bryce







More information about the kernel-team mailing list