How do I upgrade the kernel after adding PPA. Need to patch for fix to Synaptic touchpad on vostro v13 -- wireless now fails

Simon Hook simon.j.hook at jpl.nasa.gov
Sat Aug 21 01:59:19 UTC 2010


Tim Gardner wrote:
> On 08/20/2010 08:19 AM, Simon Hook wrote:
>> Tim Gardner wrote:
>>> On 08/20/2010 07:11 AM, Tim Gardner wrote:
>>>> On 08/19/2010 10:48 PM, Simon Hook wrote:
>>>>> Hi,
>>>>>
>>>>> I have a Dell Vostro v13 with Ubuntu 10.04 2.6.32-24-generic.
>>>>> Unfortunately the synaptics touchpad is not recognized and assigned
>>>>> to a
>>>>> generic mouse driver. The generic driver skips and does not support
>>>>> side
>>>>> scrolling. The bug has been submitted to launchpad and is described
>>>>> here:
>>>>> Bug #380126</bugs/380126>
>>>>> Bug #545565</bugs/545565>
>>>>>
>>>>> Recently I was pointed to a kernel patch which should fix it but the
>>>>> patch generates errors when applied to my kernel version but I was 
>>>>> told
>>>>> the patch would work with the latest kernel and I could use the 
>>>>> ppa to
>>>>> get the latest kernel.
>>>>>
>>>>> https://edge.launchpad.net/~kernel-ppa/+archive/ppa
>>>>> <https://edge.launchpad.net/%7Ekernel-ppa/+archive/ppa>
>>>>>
>>>>> I have added the ppa as a software source and done an apt-get update
>>>>> but
>>>>> my system has not updated and I do not know what I am doing wrong. 
>>>>> Here
>>>>> are the steps I have been through:
>>>>>
>>>>> https://answers.launchpad.net/dell-recovery/+question/121518
>>>>>
>>>>> How do I install the latest kernel so I can try the patch. The 
>>>>> problem
>>>>> is really annoying and affects numerous people.
>>>>>
>>>>> thanks for any help -- S.
>>>>>
>>>>
>>>> You'll be wanting to install one of the LTS backport meta packages. 
>>>> Now
>>>> that you've added the software source entry, you can search for a
>>>> package, i.e.,
>>>>
>>>> sudo apt-get update
>>>> apt-cache search lts
>>>>
>>>> The package you likely want (since you have a desktop) is
>>>> linux-image-generic-lts-backport-maverick, i.e.,
>>>>
>>>> sudo apt-get install linux-image-generic-lts-backport-maverick
>>>>
>>>> which will also install all of its dependencies, namely
>>>> linux-image-2.6.35-17-generic.
>>>>
>>>> This meta package will continue to depend on the latest LTS backport
>>>> kernel, regardless of package name changes caused by ABI bumps.
>>>>
>>>> rtg
>>>
>>> As a follow-up, the kernel you should expect is currently
>>> linux-image-2.6.35-16-generic. The -17- kernel is still building, so I
>>> have yet to update the meta package.
>> Hi well the kernel upgrade worked except now my wireless stopped
>> working. In addition the patch to the mouse driver gave exactly the same
>> errors as under 10.04 2.6.32-24-generic. How do I revert the kernel back
>> to 2.6.32-24-generic so I can get wireless back?
>>
>> thanks, Simon
>>
>> p.s. FYI. When I first upgraded to 10.04 I had to go on to a wired
>> conenction and do an update to get the latest patches to get wireless to
>> work which I did not have to do with 9.04.
>>
>
> Hmm, its curious the wireless stopped working. Perhaps you're unlucky 
> enough to have a Broadcom wireless chipset.
>
> You can uninstall the LTS kernel thusly:
>
> sudo apt-get remove linux-image-2.6.35-16-generic
>
> rtg
Hi Tim,
I ran:
sudo apt-get remove linux-image-2.6.35-16-generic
and rebooted and wireless is back working.

I ran:
lpsci -vvv

and indeed I have a:
Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)

Thank you again for all the help. I am really disappointed I could not 
fix this, I have been trying for months.  One thing I am still puzzled 
by is did I issue the patch command correctly? Any ideas how I might get 
this fixed?
thanks, Simon





More information about the kernel-team mailing list