Threaded interrupts and preemption

Alessio Igor Bogani abogani at ubuntu.com
Tue Apr 13 19:44:04 UTC 2010


Hi Chase,

2010/4/13 Chase Douglas <chase.douglas at canonical.com>:
[...]
>> I think I was confusing the -rt kernel with the -preempt flavor of the
>> ubuntu kernel tree. Unfortunately, I see that the linux-rt kernel is
>> still 2.6.31 in Lucid. Are there any plans for updating this to .33?

No for Lucid at least. I would want stick on PREEMPT_RT stable release
(that is 2.6.31) to honor our LTS guidelines.
In this sense 2.6.31 should be next official kernel for MRG.

> Also, where's the source for the -rt kernel? I'm having a hard time
> finding it. The linux-meta-rt package seems to have just some of the
> debian packaging, but no source or patches.

You should do this to obtain sources:
apt-get source linux-image-2.6.31-10-rt

If you simply do:
apt-get source linux-rt or linux-image-rt
You only receive meta package sources.

Please note that this tip are valid also for all our kernels (-generic
included).

Ciao,
Alessio




More information about the kernel-team mailing list