[PATCH] psmouse: touchpad doesn't reconnect after resume: Synaptics ps2 Bug: 551234

Stefan Bader stefan.bader at canonical.com
Thu Apr 1 09:20:07 UTC 2010

Peter M. Petrakis wrote:
> Stefan,
> I think we tried that, but I retested again just to be sure
> with a live image and it still fails with that option. Also,
> removing and reinserting the psmouse mod doesn't make a
> difference.
> Peter
> On 03/30/2010 05:46 AM, Stefan Bader wrote:
>> Peter M. Petrakis wrote:
>>> Hi All,
>>> This is my first stab at correcting some PS/2 misbehavior when returning
>>> from S3. Fire away :). Thanks.
>>> Peter
>>> P.S. Collaborated with Colin King on this one.
>> Hm, just a question. Have you tried using "i8042.reset=1" in the boot command
>> line while getting it to work(without your patch applied)? Knowing Coling likely
>> yes. But to be sure here...
>> Stefan

Ok, sorry for the delayed response. First off, I assume this is requested for
Lucid, right?
Also such changes should rather go upstream, to be discussed there and then
could be accepted back. And for that it seems like we want code like that only
applied / executed on specific hardware. Which means it would need some sort of
quirk table code to only be used on that hardware.


More information about the kernel-team mailing list