Questions about LTS backports to Hardy

Colin Watson cjwatson at ubuntu.com
Wed Jun 24 18:42:40 BST 2009


On Wed, Jun 24, 2009 at 11:34:48AM -0600, Tim Gardner wrote:
> I'm working on backporting recent kernels to LTS releases such as Hardy.
> 
> https://blueprints.edge.launchpad.net/ubuntu/+spec/kernel-karmic-new-kernel-on-lts
> 
> I'm wondering if I should create a new Hardy meta package, e.g.,
> linux-meta-2.6.28_2.6.28* ?  The package that users would be instructed
> to install would then be of the form:
> 
> linux-image-server-2.6.28_2.6.28*${arch}.deb
> 
> which would obviously pull in the dependent kernel packages.

I think that makes sense, yes. You might want to be a bit careful about
the couple of binary packages that are -2.6.28 rather than
-2.6.28-ABI-FLAVOUR, but that are built by the main kernel source
package - IIRC linux-doc-2.6.28 and linux-source-2.6.28 fall into this
category. Just leaving those out of linux-meta-2.6.28 would be good
enough.

-- 
Colin Watson                                       [cjwatson at ubuntu.com]



More information about the kernel-team mailing list