[PATCH 1/7] UBUNTU: [Config] Dove Configuration, AppArmor

Brad Figg brad.figg at canonical.com
Tue Aug 25 16:16:49 BST 2009


Signed-off-by: Brad Figg <brad.figg at canonical.com>
---
 debian.mvl-dove/config/config.common.ubuntu |    9 +++++++--
 1 files changed, 7 insertions(+), 2 deletions(-)

diff --git a/debian.mvl-dove/config/config.common.ubuntu b/debian.mvl-dove/config/config.common.ubuntu
index ec55ce1..b3f073a 100644
--- a/debian.mvl-dove/config/config.common.ubuntu
+++ b/debian.mvl-dove/config/config.common.ubuntu
@@ -150,7 +150,7 @@ CONFIG_ATM_MPOA=m
 # CONFIG_ATM_SOLOS is not set
 # CONFIG_ATM_TCP is not set
 # CONFIG_ATM_ZATM is not set
-# CONFIG_AUDIT is not set
+CONFIG_AUDIT_GENERIC=y
 CONFIG_AUFS_BDEV_LOOP=y
 # CONFIG_AUFS_BRANCH_MAX_1023 is not set
 CONFIG_AUFS_BRANCH_MAX_127=y
@@ -1934,13 +1934,16 @@ CONFIG_SCTP_HMAC_MD5=y
 # CONFIG_SDIO_UART is not set
 CONFIG_SECURITY=y
 CONFIG_SECURITYFS=y
-# CONFIG_SECURITY_APPARMOR is not set
+CONFIG_SECURITY_APPARMOR_BOOTPARAM_VALUE=1
+# CONFIG_SECURITY_APPARMOR_DISABLE is not set
+CONFIG_SECURITY_APPARMOR_NETWORK=y
 CONFIG_SECURITY_DEFAULT="apparmor"
 CONFIG_SECURITY_FILE_CAPABILITIES=y
 CONFIG_SECURITY_NETWORK=y
 # CONFIG_SECURITY_NETWORK_XFRM is not set
 CONFIG_SECURITY_PATH=y
 # CONFIG_SECURITY_ROOTPLUG is not set
+# CONFIG_SECURITY_SELINUX is not set
 CONFIG_SECURITY_TOMOYO=y
 CONFIG_SELECT_MEMORY_MODEL=y
 CONFIG_SENSORS_AD7414=m
@@ -2525,3 +2528,5 @@ CONFIG_ZISOFS=y
 CONFIG_ZLIB_DEFLATE=m
 CONFIG_ZLIB_INFLATE=y
 CONFIG_ZONE_DMA_FLAG=0
+CONFIG_SECURITY_APPARMOR=y
+CONFIG_AUDIT=y
-- 
1.6.0.4




More information about the kernel-team mailing list