[PATCH] Cleaning up the kernel postinst script

Matt Zimmerman mdz at ubuntu.com
Thu Aug 20 15:43:44 UTC 2009


On Thu, Aug 20, 2009 at 08:02:58AM -0600, Tim Gardner wrote:
> Matt Zimmerman wrote:
> > We could continue to use the massively complex one for ports if that's
> > needed, but I think x86+x86_64 could be much, much simpler.
> > 
> > What do you think?
> 
> I've applied the enhanced error reporting patch to Karmic. As for the
> larger question, I'd be happy to use an arch dependent postinst that is
> tuned for PC platforms, but I'd likely need to work with someone on the
> foundations team (my perl skills have long since atrophied).

One of the ways in which it could be simplified would be to rewrite it in
POSIX sh instead of perl.  Most of the meat in it is calls to system()
anyway.

> It seems like something one _really_ wants to get correct.

Indeed, so the simpler the better, in my book.

-- 
 - mdz




More information about the kernel-team mailing list