Does the kernel 2.6.24-18.32 support KGDB??

Amit Kucheria amit at ubuntu.com
Mon Sep 22 16:46:01 UTC 2008


On Mon, Sep 22, 2008 at 10:56 AM, rod_wang <rod_wang at pegatroncorp.com> wrote:
>  Hi,
>
>
>
>         I have a question about kernel 2.6.24-18.32. Is it support the
>
> KGDB???
>

>
> How can I make the kernel support KGDB , If the kernel doesn't support.
>

The 2.6.24 kernels do not have built-in support for KGDB. KGDB support
was integrated in 2.6.26. You have two options:

1. Install a newer kernel e.g. the intrepid kernel
2. Find KGDB patches for 2.6.24 and compile your own kernel.

Regards,
Amit




More information about the kernel-team mailing list