New (100 series) restricted NVIDIA drivers

Attila Áfra attila.afra at gmail.com
Wed Aug 8 12:20:59 UTC 2007


Hi,

The NVIDIA drivers in linux-restricted-modules are rather outdated (especially
nvidia-glx-new), so I think they should be updated to the newest versions:

Latest Version: 100.14.11
Latest Legacy GPU version (1.0-71xx series): 1.0-7185
Latest Legacy GPU version (1.0-96xx series): 1.0-9639

The 100 series driver adds support for many new GPUs (lots of GeForce 8 series
and next generation Quadro cards) and fixes many bugs (e.g. Bug #88152). I've
attached the release highlights of the drivers newer than the included ones in
Ubuntu. In my opinion, it is very important to include these new drivers in
Gutsy. Is it possible?

I would also like to note that the current nvidia-glx-new (9755) package is
incomplete (Bug #98641, first reported on 2007-03-29), because a
required library,
"libwfb", is not included, but which is present in the official NVIDIA driver
package (the solution is posted to launchpad). This library is required by the
100 series drivers too.

Finally, there is an NVIDIA related bug in lrm-manager (Bug #105756, first
reported on 2007-04-12). Should I post the patch here or to launchpad (or maybe
elsewhere)?

Thank you.

Regards,
Attila
-------------- next part --------------
Version 100.14.11:
    * Added support for new GPUs:
          o GeForce 7050 PV / NVIDIA nForce 630a
          o GeForce 7025 / NVIDIA nForce 630a

    * Fixed console restore problems in several different configurations:
          o Quadro FX 4400 SLI
          o VESA console
          o Notebook LCD displays

    * Improved interaction with ATi RS480/482 based mainboards.
    * Improved support for House Sync with G-Sync II.
    * Improved NVIDIA X driver interaction with ACPI daemon.


Version 100.14.09:
    * Adds support for new GPUs:
          o GeForce 8600 GTS
          o GeForce 8600 GT
          o GeForce 8600M GT
          o GeForce 8600M GS
          o GeForce 8500 GT
          o GeForce 8400 GS
          o GeForce 8400M GT
          o GeForce 8400M GS
          o GeForce 8400M G
          o GeForce 8300 GS
          o Quadro FX 1600M
          o Quadro FX 570M
          o Quadro FX 360M
          o Quadro NVS 320M
          o Quadro NVS 140M
          o Quadro NVS 135M
          o Quadro NVS 130M

    * Adds support for Quadro FX 4600 G-Sync and Quadro FX 5600 G-Sync boards.
    * Improved notebook GPU support.
    * Improved RenderAccel support for subpixel antialiased fonts.
    * Added XV brightness and contrast controls for GeForce 8 GPUs.
    * Improved interaction with newer Linux kernels.
    * Fixed a locale-interaction issue in the nvidia-settings configuration file parser.


Version 100.14.06:
    * Improved Notebook support.
    * Fixed assorted minor bugs.


Version 100.14.03:
    * Added support for GeForce 8600 GTS, GeForce 8600 GT, GeForce 8500 GT, GeForce 8400 GS,
      and GeForce 8300 GS


-------------- next part --------------
Version 1.0-9639:
    * Improved interaction with newer Linux kernels.
    * Improved compatibility with newer versions of X.Org.
-------------- next part --------------
Version 1.0-7185:
    * Improved interaction with newer Linux kernels. 
    * Improved compatibility with newer versions of X.Org.
    * Added new NVIDIA logo artwork to nvidia-settings and X driver splashscreen.


More information about the kernel-team mailing list