[DRI bug]video card ATI Radeon X300

Daniel Moyne dmoyne at tiscali.fr
Wed May 3 09:33:47 UTC 2006


Hopefully you are the guys to contact to for bug report on DRI with Ubuntu 
DapperDrake LTS :

I have the following configuration :

machine : x86_64
distribution : Dapper Drake LTS 64 bits
kernel : 2.6.15-21-amd64-k8

I am using "fglrx" driver for my video card ATI Radeon X300 video card 
as "ati" driver has never worked ; when using "fgl_glxgears" I collect the 
following error message as the app is crashing :
Using GLX_SGIX_pbuffer
Exception en point flottant

Though when using "glxinfo" I get the following :

name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
.................

When using "glxgears" the video animation is apparently running well untill an 
unexpected interruption freezes the display for a short while before the 
display resumes normal behaviour and dsiplay problem is back !


For your information it is working on Breezy with the following 
configuration :
kernel : 2.6.12-10-amd64-k8
and also fwith the "fglrx" driver which in this case is using an old libdri.a 
library as recommended by a user (on Dapper Drake LTS it is using libdri.so 
which might have a link to the bug ?).

In both cases my xorg.cong has theses lines :

Section "Device"
	Identifier	"ATI Technologies, Inc. Radeon X300 SE (RV370)"
	Driver		"fglrx"
        Option      	"UseInternalAGPGART" "no"
        Option      	"KernelModuleParm" "agplock=0"
	BusID		"PCI:5:0:0"
EndSection

I can run further tests shouls you wish me to do so.

Regards.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 191 bytes
Desc: not available
URL: <https://lists.ubuntu.com/archives/kernel-team/attachments/20060503/e769648a/attachment.pgp>


More information about the kernel-team mailing list