[Bug 670232] [NEW] Ethernet multicasts are not received after suspend

Benjamin Jencks ben at bjencks.net
Wed Nov 3 05:14:13 UTC 2010


Public bug reported:

After suspend and resume, it appears that my eth0 stops receiving
multicast frames. IPv6 is my test case, because I don't have any other
protocols handy that generate multicasts. When it's in this condition, I
can ping6 other link-local addresses (send out multicast, receive
unicast), but I don't receive router advertisements, and ping6 ff02::1
on another host isn't received. I've verified with tcpdump that the
packets aren't being seen at all.

I can resolve the situation by doing
$ sudo ip link set dev eth0 promisc on
$ sudo ip link set dev eth0 promisc off
after which everything works as expected.

There are no iptables or ip6tables rules in place.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-25-generic 2.6.32-25.45
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-25.45-generic 2.6.32.21+drm33.7
Uname: Linux 2.6.32-25-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf9ff8000 irq 22'
   Mixer name	: 'Realtek ALC1200'
   Components	: 'HDA:10ec0888,104382fe,00100101'
   Controls      : 40
   Simple ctrls  : 22
Date: Wed Nov  3 01:03:16 2010
HibernationDevice: RESUME=UUID=871e7f67-1e86-4b04-bfcf-019835f0d9be
IwConfig:
 lo        no wireless extensions.
 
 eth0      no wireless extensions.
MachineType: System manufacturer P5QL PRO
ProcCmdLine: root=UUID=9b35165c-0c33-4b2e-b68e-7a7e4dda16c7 ro
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34.1
RfKill:
 
SourcePackage: linux
UserAsoundrc:
 
WpaSupplicantLog:
 
dmi.bios.date: 06/18/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0402
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5QL PRO
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0402:bd06/18/2008:svnSystemmanufacturer:pnP5QLPRO:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5QLPRO:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5QL PRO
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

** Affects: linux (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: amd64 apport-bug lucid needs-upstream-testing resume suspend

-- 
Ethernet multicasts are not received after suspend
https://bugs.launchpad.net/bugs/670232
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to linux in ubuntu.




More information about the kernel-bugs mailing list