[Bug 604904] [NEW] Passphrase dialog at boot for LUKS-encrypted root volume disappears after first character entered

Oliver Hookins ohookins at gmail.com
Tue Jul 13 07:21:37 UTC 2010


Public bug reported:

Binary package hint: initramfs-tools

Background:
1. I'm not positive if initramfs-tools is the correct package for this bug, but it's my best guess.
2. I have a Lenovo x301 with the DisplayPort connected to an external monitor. I do not use the built-in LCD at all.
3. Ubuntu 10.04 LTS

Steps to reproduce:
1. Connect DisplayPort to an external monitor and close notebook lid immediately after power on.
2. All boot messages are displayed on external monitor up until and including the LUKS graphical dialog prompting for the root-volume's passphrase.
3. Start to enter the passphrase
4. Screen completely blanks after the first character is entered, which prevents any further indication of characters entered.

Expected results:
1. Screen does not blank during the typing of the passphrase.

When using the built-in LCD, this problem does not occur so I assume it
is some kind of problem with the interaction with the external display
port and how the typing progress is drawn onto the screen.

** Affects: initramfs-tools (Ubuntu)
     Importance: Undecided
         Status: New

-- 
Passphrase dialog at boot for LUKS-encrypted root volume disappears after first character entered
https://bugs.launchpad.net/bugs/604904
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to initramfs-tools in ubuntu.




More information about the kernel-bugs mailing list