[Bug 574910] Re: High load averages on Lucid while idling

Russell Branca 574910 at bugs.launchpad.net
Fri Jul 9 18:11:19 UTC 2010


I'm running into the same issues on the Lucid 64bit EBS AMI, except with
much higher load:

$ uptime
 18:06:22 up 18:31,  2 users,  load average: 12.16, 13.54, 13.78


$ top -bn1 | head -20
top - 18:06:52 up 18:32,  2 users,  load average: 11.53, 13.19, 13.65
Tasks: 108 total,   1 running, 107 sleeping,   0 stopped,   0 zombie
Cpu(s):  4.4%us,  0.9%sy,  0.0%ni, 92.2%id,  0.2%wa,  0.0%hi,  0.0%si,  2.4%st
Mem:   7864548k total,  3910252k used,  3954296k free,   194372k buffers
Swap:        0k total,        0k used,        0k free,   461708k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                                                                  
    1 root      20   0 23704 1896 1268 S    0  0.0   0:00.15 init                                                                                                     
    2 root      20   0     0    0    0 S    0  0.0   0:00.00 kthreadd                                                                                                 
    3 root      RT   0     0    0    0 S    0  0.0   0:00.00 migration/0                                                                                              
    4 root      20   0     0    0    0 S    0  0.0   0:00.00 ksoftirqd/0                                                                                              
    5 root      RT   0     0    0    0 S    0  0.0   0:00.00 watchdog/0                                                                                               
    6 root      20   0     0    0    0 S    0  0.0   0:00.00 events/0                                                                                                 
    7 root      20   0     0    0    0 S    0  0.0   0:00.00 cpuset                                                                                                   
    8 root      20   0     0    0    0 S    0  0.0   0:00.00 khelper                                                                                                  
    9 root      20   0     0    0    0 S    0  0.0   0:00.00 netns                                                                                                    
   10 root      20   0     0    0    0 S    0  0.0   0:00.00 async/mgr                                                                                                
   11 root      20   0     0    0    0 S    0  0.0   0:00.00 xenwatch                                                                                                 
   12 root      20   0     0    0    0 S    0  0.0   0:00.00 xenbus                                                                                                   
   14 root      RT   0     0    0    0 S    0  0.0   0:00.00 migration/1          



$ iostat -k
Linux 2.6.32-305-ec2 (ip-10-196-38-176) 	07/09/2010 	_x86_64_	(2 CPU)

avg-cpu:  %user   %nice %system %iowait  %steal   %idle
           4.35    0.00    0.94    0.16    2.36   92.20

Device:            tps    kB_read/s    kB_wrtn/s    kB_read    kB_wrtn
sda1              3.10         3.79        15.36     252813    1025840
sdb               0.00         0.01         0.00        381         24


$ uptime
 18:07:45 up 18:33,  2 users,  load average: 15.13, 13.87, 13.85


I have about 30 workers for misc programs running that are sitting idle,
I'm moving over from a debian lenny box at a colo with nearly identical
specs running slightly more workers with the same general setup, and the
load is sitting at around 1 on that box.

-- 
High load averages on Lucid while idling
https://bugs.launchpad.net/bugs/574910
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to linux-meta in ubuntu.




More information about the kernel-bugs mailing list