[Bug 323159] Re: I/O Errors with O2Micro sdhci PCI MMC/SD host controller v2

Johnathan Morlock 323159 at bugs.launchpad.net
Thu Jul 8 06:27:46 UTC 2010


Hey everyone,

Using a Dell Vostro 1720, getting the same issue with Lucid kernel:
2.6.32-23-generic.

dmesg:
--------------------------------------------------------------------------------------------------------------------------------------------------
[   22.305734] sdhci-pci 0000:1a:00.1: SDHCI controller found [1217:8120] (rev 1)
[   22.305775] sdhci-pci 0000:1a:00.1: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[   22.305805] mmc0: Unknown controller version (2). You may experience problems.
[   22.305983] sdhci-pci 0000:1a:00.1: Will use DMA mode even though HW doesn't fully claim to support it.
[   22.305997] sdhci-pci 0000:1a:00.1: setting latency timer to 64
[   22.306039] Registered led device: mmc0::
[   22.306082] mmc0: SDHCI controller on PCI [0000:1a:00.1] using DMA
--------------------------------------------------------------------------------------------------------------------------------------------------

Same for syslog:
--------------------------------------------------------------------------------------------------------------------------------------------------
Jul  8 00:37:26 7727609341 kernel: [   22.305734] sdhci-pci 0000:1a:00.1: SDHCI controller found [1217:8120] (rev 1)
Jul  8 00:37:26 7727609341 kernel: [   22.305775] sdhci-pci 0000:1a:00.1: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Jul  8 00:37:26 7727609341 kernel: [   22.305805] mmc0: Unknown controller version (2). You may experience problems.
Jul  8 00:37:26 7727609341 kernel: [   22.305983] sdhci-pci 0000:1a:00.1: Will use DMA mode even though HW doesn't fully claim to support it.
Jul  8 00:37:26 7727609341 kernel: [   22.305997] sdhci-pci 0000:1a:00.1: setting latency timer to 64
Jul  8 00:37:26 7727609341 kernel: [   22.306039] Registered led device: mmc0::
Jul  8 00:37:26 7727609341 kernel: [   22.306082] mmc0: SDHCI controller on PCI [0000:1a:00.1] using DMA
--------------------------------------------------------------------------------------------------------------------------------------------------


$ lspci | grep SD
1a:00.1 SD Host controller: O2 Micro, Inc. Device 8120 (rev 01)


NOTE: For me my card reader works fine after boot. But boot suffers a good 15 second delay due to this. It is annoying.

Thank you and God bless,
Johnathan

-- 
I/O Errors with O2Micro sdhci PCI MMC/SD host controller v2
https://bugs.launchpad.net/bugs/323159
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to linux in ubuntu.




More information about the kernel-bugs mailing list