[Bug 519910] Re: package linux-headers-2.6.31-19-generic 2.6.31-19.56 failed to install/upgrade

Gene kenderclan at gmail.com
Sun Feb 28 08:59:40 UTC 2010


My problems are solved so far. Here is a mail exchange in case anyone
has similar problems.

-------------------------------------------------------------------------------------------------------------------

Hi Stefan,

sorry for the delay, your advice  with "purge" was the solution, and I
did it right away.(apt-get remove --purge dkms)

However, before writing an answer to you and a comment to the bug
report, I had to see that the wireless worked as well.

It didn't.

In the past (1-2 months ago) I had the problem that, even though I did
everything as indicated on the official broadcom site to download and
install the 802.11 Linux STA driver, at boot it would always load the
wrong modules. With help from linux-wlan-client-support-
list at broadcom.com I was able to change the boot image (with "update-
initramfs -u") and it booted correctly ever since - until this version
2.6.31.19.32

Now since I had this bug signalled, I tried to repeat the exact same
steps, but changing the boot image did not work anymore (I could do it,
but at reboot nothing changed). I suppose it had to do with the bug,
smth with meddling with the image, but I don't understand enough to
follow the exact problem.

So the solution now was that I had to make my own script to be run at
boot time. Now everything works, but I am concerned as to why the script
was necessary at all.

The script consists of just these two lines:

sudo modprobe lib80211
sudo insmod /lib/modules/2.6.31-19-generic/kernel/drivers/net/wireless/wl.ko

Thanks, and maybe this info is helpful to others, so I am posting it on
the bug report page as well, as you suggested.

Gene

Stefan Potyra wrote:
> Hi Gene,
>
> Am Saturday 13 February 2010 21:22:29 schrieben Sie:
>  
>> Hi Stefan,
>>
>> I hope it's not terribly bad manners to write emails directly (if it is,
>> please tell me so!), but --
>>     
>
> I don't feel this as impolite, however it imho doesn't hurt to CC the bug report in question, otherwise the info might just get lost (I'm by far no expert in regards to dkms).
>
>  
>> Regarding the "claimed fixed" bug #480055 in dkms/Ubuntu, I wasn't sure
>> anyone would read comments if the bug is reported fixed.
>>
>> If you care to check the (my) bug report #519910, you might conclude the
>> fix didn't work. (Of course it might just be another problem)
>>     
>
> Just from the bug report, I cannot really tell this. Basically, there seem to be two problems: 1) old dkms scripts tried to execute possibly non-existant scripts
> -> that was fixed, but... (see below)
> 2) a different problem resulting in empty files. Speculation has it that it is ext4 related, but the real reason is not yet found afaict.
>
>  
>> After checking several possible solutions recommended for related bugs -
>> like removing nvidia-common completely, trying to reinstall dkms from
>> Synaptic, trying to upgrade, etc nothing works, I always get stuck with
>> linux-image-2.6.31-19-generic trying to be configured etc
>>
>> I looked and my dkms is empty (I had dkms and nvidia-common in
>> /etc/kernel/postinst.d, dkms was empty, nvidia was not, after removing
>> nvidia with synaptic manager I am left with the empty dkms) and there is
>> no dkms_autoinstaller in /var/lib/dkms.
>>
>> Anything else I might try?
>>     
>
> The dkms problem was that if a package is removed (e.g. dkms), then the scripts remain in /etc, as removing a package doesn't remove any conffiles. By default any file in /etc is marked as a conffile.
> If you try to reinstall dkms, does it prompt you with a question if the empty file in question should get overwritten? (I'd expect that).
>
> I think you could try to purge dkms (apt-get remove --purge dkms). After you've purged dkms, please make sure that there is no empty file from it left in /etc. If so, manually delete it. In case apt is not happy yet, you could try to run "dpkg --reconfigure -a", in the hope that this will get the installed packages back in a sane state. Finally you should be able to reinstall dkms which hopefully won't result in an empty file.
>
> Hope this helps. If it does, please post what you did to your bug report, maybe others have the same problem.
>
> Cheers,
>    Stefan.
>

-- 
package linux-headers-2.6.31-19-generic 2.6.31-19.56 failed to install/upgrade
https://bugs.launchpad.net/bugs/519910
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to linux in ubuntu.




More information about the kernel-bugs mailing list