[Bug 517721] [NEW] package linux-image-2.6.31-19-generic 2.6.31-19.56 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

mercutio22 macabro22 at gmail.com
Fri Feb 5 18:34:07 UTC 2010


Public bug reported:

Binary package hint: initramfs-tools

A poput message says

E: linux-image-2.6.31-19-generic: subprocess installed post-installation script returned error exit status 2
E: linux-backports-modules-2.6.31-19-generic: dependency problems - leaving unconfigured
E: linux-backports-modules-karmic-generic: dependency problems - leaving unconfigured
E: linux-backports-modules-karmic: dependency problems - leaving unconfigured
E: linux-backports-modules-wireless-karmic-generic: dependency problems - leaving unconfigured
E: linux-image-generic: dependency problems - leaving unconfigured
E: linux-image: dependency problems - leaving unconfigured
E: linux-generic: dependency problems - leaving unconfigured

===============
The synaptic terminal window showed:

(Reading database ... 30%
dpkg: warning: files list file for package `linux-image-2.6.31-15-generic' missing, assuming package has no files currently installed.
(Reading database ... 35%
dpkg: warning: files list file for package `linux-backports-modules-wireless-karmic-generic' missing, assuming package has no files currently installed.
(Reading database ... 50%
dpkg: warning: files list file for package `linux-image-2.6.31-14-generic' missing, assuming package has no files currently installed.
(Reading database ... 55%
dpkg: warning: files list file for package `linux-image-2.6.31-17-generic' missing, assuming package has no files currently installed.
(Reading database ... 65%
dpkg: warning: files list file for package `linux-image-2.6.31-16-generic' missing, assuming package has no files currently installed.
(Reading database ... 70%
dpkg: warning: files list file for package `linux-backports-modules-2.6.31-16-generic' missing, assuming package has no files currently installed.
(Reading database ... 80%
dpkg: warning: files list file for package `linux-backports-modules-2.6.31-17-generic' missing, assuming package has no files currently installed.
(Reading database ... 346471 files and directories currently installed.)
Preparing to replace google-chrome-unstable 5.0.307.1-r37331 (using .../google-chrome-unstable_5.0.307.5-r37950_i386.deb) ...
Unpacking replacement google-chrome-unstable ...
Selecting previously deselected package linux-image-2.6.31-19-generic.
Unpacking linux-image-2.6.31-19-generic (from .../linux-image-2.6.31-19-generic_2.6.31-19.56_i386.deb) ...
Done.
Selecting previously deselected package linux-backports-modules-2.6.31-19-generic.
Unpacking linux-backports-modules-2.6.31-19-generic (from .../linux-backports-modules-2.6.31-19-generic_2.6.31-19.21_i386.deb) ...
Preparing to replace linux-backports-modules-karmic 2.6.31.17.30 (using .../linux-backports-modules-karmic_2.6.31.19.32_i386.deb) ...
Unpacking replacement linux-backports-modules-karmic ...
Preparing to replace linux-backports-modules-karmic-generic 2.6.31.17.30 (using .../linux-backports-modules-karmic-generic_2.6.31.19.32_i386.deb) ...
Unpacking replacement linux-backports-modules-karmic-generic ...
Preparing to replace linux-backports-modules-wireless-karmic-generic 2.6.31.17.30 (using .../linux-backports-modules-wireless-karmic-generic_2.6.31.19.32_i386.deb) ...
Unpacking replacement linux-backports-modules-wireless-karmic-generic ...
Preparing to replace linux-image 2.6.31.17.30 (using .../linux-image_2.6.31.19.32_i386.deb) ...
Unpacking replacement linux-image ...
Preparing to replace linux-generic 2.6.31.17.30 (using .../linux-generic_2.6.31.19.32_i386.deb) ...
Unpacking replacement linux-generic ...
Preparing to replace linux-image-generic 2.6.31.17.30 (using .../linux-image-generic_2.6.31.19.32_i386.deb) ...
Unpacking replacement linux-image-generic ...
Selecting previously deselected package linux-headers-2.6.31-19.
Unpacking linux-headers-2.6.31-19 (from .../linux-headers-2.6.31-19_2.6.31-19.56_all.deb) ...
Selecting previously deselected package linux-headers-2.6.31-19-generic.
Unpacking linux-headers-2.6.31-19-generic (from .../linux-headers-2.6.31-19-generic_2.6.31-19.56_i386.deb) ...
Preparing to replace linux-headers-generic 2.6.31.17.30 (using .../linux-headers-generic_2.6.31.19.32_i386.deb) ...
Unpacking replacement linux-headers-generic ...
Processing triggers for man-db ...
Setting up google-chrome-unstable (5.0.307.5-r37950) ...

Setting up linux-image-2.6.31-19-generic (2.6.31-19.56) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.31-19-generic
: RESUME=/dev/sda2 is not a valid kernel version
update-initramfs: failed for /boot/initrd.img-2.6.31-19-generic
Failed to create initrd image.
dpkg: error processing linux-image-2.6.31-19-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-backports-modules-2.6.31-19-generic:
 linux-backports-modules-2.6.31-19-generic depends on linux-image-2.6.31-19-generic; however:
  Package linux-image-2.6.31-19-generic is not configured yet.
dpkg: error processing linux-backports-modules-2.6.31-19-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-backports-modules-karmic-generic:
 linux-backports-modules-karmic-generic depends on linux-backports-modules-2.6.31-19-generic; however:
  Package linux-backports-modules-2.6.31-19-generic is not configured yet.
dpkg: error processing linux-backports-modules-karmic-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: No apport report written because the error message indicates its a followup error from a previous failure.
                                No apport report written because the error message indicates its a followup error from a previous failure.
                                                          No apport report written because MaxReports is reached already
                                        No apport report written because MaxReports is reached already
                      No apport report written because MaxReports is reached already
    No apport report written because MaxReports is reached already
                                                                  No apport report written because MaxReports is reached already
                                                dependency problems prevent configuration of linux-backports-modules-karmic:
 linux-backports-modules-karmic depends on linux-backports-modules-karmic-generic (= 2.6.31.19.32); however:
  Package linux-backports-modules-karmic-generic is not configured yet.
dpkg: error processing linux-backports-modules-karmic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-backports-modules-wireless-karmic-generic:
 linux-backports-modules-wireless-karmic-generic depends on linux-backports-modules-2.6.31-19-generic; however:
  Package linux-backports-modules-2.6.31-19-generic is not configured yet.
dpkg: error processing linux-backports-modules-wireless-karmic-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-generic:
 linux-image-generic depends on linux-image-2.6.31-19-generic; however:
  Package linux-image-2.6.31-19-generic is not configured yet.
dpkg: error processing linux-image-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image:
 linux-image depends on linux-image-generic (= 2.6.31.19.32); however:
  Package linux-image-generic is not configured yet.
dpkg: error processing linux-image (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic:
 linux-generic depends on linux-image-generic (= 2.6.31.19.32); however:
  Package linux-image-generic is not configured yet.
dpkg: error processing linux-generic (--configure):
 dependency problems - leaving unconfigured
Setting up linux-headers-2.6.31-19 (2.6.31-19.56) ...
Setting up linux-headers-2.6.31-19-generic (2.6.31-19.56) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/nvidia-common

Setting up linux-headers-generic (2.6.31.19.32) ...
Errors were encountered while processing:
 linux-image-2.6.31-19-generic
 linux-backports-modules-2.6.31-19-generic
 linux-backports-modules-karmic-generic
 linux-backports-modules-karmic
 linux-backports-modules-wireless-karmic-generic
 linux-image-generic
 linux-image
 linux-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up linux-image-2.6.31-19-generic (2.6.31-19.56) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.31-19-generic
: RESUME=/dev/sda2 is not a valid kernel version
update-initramfs: failed for /boot/initrd.img-2.6.31-19-generic
Failed to create initrd image.
dpkg: error processing linux-image-2.6.31-19-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-image-generic:
 linux-image-generic depends on linux-image-2.6.31-19-generic; however:
  Package linux-image-2.6.31-19-generic is not configured yet.
dpkg: error processing linux-image-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic:
 linux-generic depends on linux-image-generic (= 2.6.31.19.32); however:
  Package linux-image-generic is not configured yet.
dpkg: error processing linux-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-backports-modules-2.6.31-19-generic:
 linux-backports-modules-2.6.31-19-generic depends on linux-image-2.6.31-19-generic; however:
  Package linux-image-2.6.31-19-generic is not configured yet.
dpkg: error processing linux-backports-modules-2.6.31-19-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-backports-modules-wireless-karmic-generic:
 linux-backports-modules-wireless-karmic-generic depends on linux-backports-modules-2.6.31-19-generic; however:
  Package linux-backports-modules-2.6.31-19-generic is not configured yet.
dpkg: error processing linux-backports-modules-wireless-karmic-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image:
 linux-image depends on linux-image-generic (= 2.6.31.19.32); however:
  Package linux-image-generic is not configured yet.
dpkg: error processing linux-image (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-backports-modules-karmic-generic:
 linux-backports-modules-karmic-generic depends on linux-backports-modules-2.6.31-19-generic; however:
  Package linux-backports-modules-2.6.31-19-generic is not configured yet.
dpkg: error processing linux-backports-modules-karmic-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-backports-modules-karmic:
 linux-backports-modules-karmic depends on linux-backports-modules-karmic-generic (= 2.6.31.19.32); however:
  Package linux-backports-modules-karmic-generic is not configured yet.
dpkg: error processing linux-backports-modules-karmic (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-image-2.6.31-19-generic
 linux-image-generic
 linux-generic
 linux-backports-modules-2.6.31-19-generic
 linux-backports-modules-wireless-karmic-generic
 linux-image
 linux-back(Reading database ... 30%
dpkg: warning: files list file for package `linux-image-2.6.31-15-generic' missing, assuming package has no files currently installed.
(Reading database ... 35%
dpkg: warning: files list file for package `linux-backports-modules-wireless-karmic-generic' missing, assuming package has no files currently installed.
(Reading database ... 50%
dpkg: warning: files list file for package `linux-image-2.6.31-14-generic' missing, assuming package has no files currently installed.
(Reading database ... 55%
dpkg: warning: files list file for package `linux-image-2.6.31-17-generic' missing, assuming package has no files currently installed.
(Reading database ... 65%
dpkg: warning: files list file for package `linux-image-2.6.31-16-generic' missing, assuming package has no files currently installed.
(Reading database ... 70%
dpkg: warning: files list file for package `linux-backports-modules-2.6.31-16-generic' missing, assuming package has no files currently installed.
(Reading database ... 80%
dpkg: warning: files list file for package `linux-backports-modules-2.6.31-17-generic' missing, assuming package has no files currently installed.
(Reading database ... 346471 files and directories currently installed.)
Preparing to replace google-chrome-unstable 5.0.307.1-r37331 (using .../google-chrome-unstable_5.0.307.5-r37950_i386.deb) ...
Unpacking replacement google-chrome-unstable ...
Selecting previously deselected package linux-image-2.6.31-19-generic.
Unpacking linux-image-2.6.31-19-generic (from .../linux-image-2.6.31-19-generic_2.6.31-19.56_i386.deb) ...
Done.
Selecting previously deselected package linux-backports-modules-2.6.31-19-generic.
Unpacking linux-backports-modules-2.6.31-19-generic (from .../linux-backports-modules-2.6.31-19-generic_2.6.31-19.21_i386.deb) ...
Preparing to replace linux-backports-modules-karmic 2.6.31.17.30 (using .../linux-backports-modules-karmic_2.6.31.19.32_i386.deb) ...
Unpacking replacement linux-backports-modules-karmic ...
Preparing to replace linux-backports-modules-karmic-generic 2.6.31.17.30 (using .../linux-backports-modules-karmic-generic_2.6.31.19.32_i386.deb) ...
Unpacking replacement linux-backports-modules-karmic-generic ...
Preparing to replace linux-backports-modules-wireless-karmic-generic 2.6.31.17.30 (using .../linux-backports-modules-wireless-karmic-generic_2.6.31.19.32_i386.deb) ...
Unpacking replacement linux-backports-modules-wireless-karmic-generic ...
Preparing to replace linux-image 2.6.31.17.30 (using .../linux-image_2.6.31.19.32_i386.deb) ...
Unpacking replacement linux-image ...
Preparing to replace linux-generic 2.6.31.17.30 (using .../linux-generic_2.6.31.19.32_i386.deb) ...
Unpacking replacement linux-generic ...
Preparing to replace linux-image-generic 2.6.31.17.30 (using .../linux-image-generic_2.6.31.19.32_i386.deb) ...
Unpacking replacement linux-image-generic ...
Selecting previously deselected package linux-headers-2.6.31-19.
Unpacking linux-headers-2.6.31-19 (from .../linux-headers-2.6.31-19_2.6.31-19.56_all.deb) ...
Selecting previously deselected package linux-headers-2.6.31-19-generic.
Unpacking linux-headers-2.6.31-19-generic (from .../linux-headers-2.6.31-19-generic_2.6.31-19.56_i386.deb) ...
Preparing to replace linux-headers-generic 2.6.31.17.30 (using .../linux-headers-generic_2.6.31.19.32_i386.deb) ...
Unpacking replacement linux-headers-generic ...
Processing triggers for man-db ...
Setting up google-chrome-unstable (5.0.307.5-r37950) ...

Setting up linux-image-2.6.31-19-generic (2.6.31-19.56) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.31-19-generic
: RESUME=/dev/sda2 is not a valid kernel version
update-initramfs: failed for /boot/initrd.img-2.6.31-19-generic
Failed to create initrd image.
dpkg: error processing linux-image-2.6.31-19-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-backports-modules-2.6.31-19-generic:
 linux-backports-modules-2.6.31-19-generic depends on linux-image-2.6.31-19-generic; however:
  Package linux-image-2.6.31-19-generic is not configured yet.
dpkg: error processing linux-backports-modules-2.6.31-19-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-backports-modules-karmic-generic:
 linux-backports-modules-karmic-generic depends on linux-backports-modules-2.6.31-19-generic; however:
  Package linux-backports-modules-2.6.31-19-generic is not configured yet.
dpkg: error processing linux-backports-modules-karmic-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: No apport report written because the error message indicates its a followup error from a previous failure.
                                No apport report written because the error message indicates its a followup error from a previous failure.
                                                          No apport report written because MaxReports is reached already
                                        No apport report written because MaxReports is reached already
                      No apport report written because MaxReports is reached already
    No apport report written because MaxReports is reached already
                                                                  No apport report written because MaxReports is reached already
                                                dependency problems prevent configuration of linux-backports-modules-karmic:
 linux-backports-modules-karmic depends on linux-backports-modules-karmic-generic (= 2.6.31.19.32); however:
  Package linux-backports-modules-karmic-generic is not configured yet.
dpkg: error processing linux-backports-modules-karmic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-backports-modules-wireless-karmic-generic:
 linux-backports-modules-wireless-karmic-generic depends on linux-backports-modules-2.6.31-19-generic; however:
  Package linux-backports-modules-2.6.31-19-generic is not configured yet.
dpkg: error processing linux-backports-modules-wireless-karmic-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-generic:
 linux-image-generic depends on linux-image-2.6.31-19-generic; however:
  Package linux-image-2.6.31-19-generic is not configured yet.
dpkg: error processing linux-image-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image:
 linux-image depends on linux-image-generic (= 2.6.31.19.32); however:
  Package linux-image-generic is not configured yet.
dpkg: error processing linux-image (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic:
 linux-generic depends on linux-image-generic (= 2.6.31.19.32); however:
  Package linux-image-generic is not configured yet.
dpkg: error processing linux-generic (--configure):
 dependency problems - leaving unconfigured
Setting up linux-headers-2.6.31-19 (2.6.31-19.56) ...
Setting up linux-headers-2.6.31-19-generic (2.6.31-19.56) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/nvidia-common

Setting up linux-headers-generic (2.6.31.19.32) ...
Errors were encountered while processing:
 linux-image-2.6.31-19-generic
 linux-backports-modules-2.6.31-19-generic
 linux-backports-modules-karmic-generic
 linux-backports-modules-karmic
 linux-backports-modules-wireless-karmic-generic
 linux-image-generic
 linux-image
 linux-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up linux-image-2.6.31-19-generic (2.6.31-19.56) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.31-19-generic
: RESUME=/dev/sda2 is not a valid kernel version
update-initramfs: failed for /boot/initrd.img-2.6.31-19-generic
Failed to create initrd image.
dpkg: error processing linux-image-2.6.31-19-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-image-generic:
 linux-image-generic depends on linux-image-2.6.31-19-generic; however:
  Package linux-image-2.6.31-19-generic is not configured yet.
dpkg: error processing linux-image-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic:
 linux-generic depends on linux-image-generic (= 2.6.31.19.32); however:
  Package linux-image-generic is not configured yet.
dpkg: error processing linux-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-backports-modules-2.6.31-19-generic:
 linux-backports-modules-2.6.31-19-generic depends on linux-image-2.6.31-19-generic; however:
  Package linux-image-2.6.31-19-generic is not configured yet.
dpkg: error processing linux-backports-modules-2.6.31-19-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-backports-modules-wireless-karmic-generic:
 linux-backports-modules-wireless-karmic-generic depends on linux-backports-modules-2.6.31-19-generic; however:
  Package linux-backports-modules-2.6.31-19-generic is not configured yet.
dpkg: error processing linux-backports-modules-wireless-karmic-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image:
 linux-image depends on linux-image-generic (= 2.6.31.19.32); however:
  Package linux-image-generic is not configured yet.
dpkg: error processing linux-image (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-backports-modules-karmic-generic:
 linux-backports-modules-karmic-generic depends on linux-backports-modules-2.6.31-19-generic; however:
  Package linux-backports-modules-2.6.31-19-generic is not configured yet.
dpkg: error processing linux-backports-modules-karmic-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-backports-modules-karmic:
 linux-backports-modules-karmic depends on linux-backports-modules-karmic-generic (= 2.6.31.19.32); however:
  Package linux-backports-modules-karmic-generic is not configured yet.
dpkg: error processing linux-backports-modules-karmic (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-image-2.6.31-19-generic
 linux-image-generic
 linux-generic
 linux-backports-modules-2.6.31-19-generic
 linux-backports-modules-wireless-karmic-generic
 linux-image
 linux-backports-modules-karmic-generic
 linux-backports-modules-karmic

ports-modules-karmic-generic
 linux-backports-modules-karmic

ProblemType: Package
Architecture: i386
Date: Fri Feb  5 16:29:17 2010
DistroRelease: Ubuntu 9.10
ErrorMessage: subprocess installed post-installation script returned error exit status 2
Package: linux-image-2.6.31-19-generic 2.6.31-19.56
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: initramfs-tools
Tags:  ubuntu-unr
Title: package linux-image-2.6.31-19-generic 2.6.31-19.56 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2
Uname: Linux 2.6.31-17-generic i686

** Affects: initramfs-tools (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: apport-package i386 ubuntu-unr

-- 
package linux-image-2.6.31-19-generic 2.6.31-19.56 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2
https://bugs.launchpad.net/bugs/517721
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to initramfs-tools in ubuntu.




More information about the kernel-bugs mailing list