[Bug 446776] [NEW] hid-ids.h is not included - Needed

gali98 korylprince at gmail.com
Thu Oct 8 22:40:45 UTC 2009

Public bug reported:

Binary package hint: linux-headers-generic

In Karmic, the file:

is not included for some reason. This file is needed to compile some programs. The one I need it for is the linux-wacom package (For Wacom tablets.) This is pretty important for that reason. 
The thing is, http://kernel.ubuntu.com/git-repos/ubuntu/linux-2.6/drivers/hid/
has the file where it should be, but it is not anywhere on the computer.
A relevant ubuntu forums thread is here:
A workaround is to just download the file and paste into the correct spot, but this is a bad fix as any update to the package may result in it getting deleted/not updated to the right place. This file was in Jaunty as far as I know. (Since I never had a problem compiling the program.)


ProblemType: Bug
Architecture: amd64
 /dev/snd/controlC0:  kory       1798 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
 Card hw:0 'NVidia'/'HDA NVidia at 0xc0000000 irq 17'
   Mixer name	: 'Realtek ALC861-VD'
   Components	: 'HDA:10ec0862,103c30e5,00100001 HDA:10573055,103c30e5,00100700'
   Controls      : 25
   Simple ctrls  : 15
Date: Thu Oct  8 17:26:22 2009
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=443da1ee-0423-4543-a6e1-7038b9a4671d
MachineType: Hewlett-Packard HP Pavilion tx2000 Notebook PC
NonfreeKernelModules: wl nvidia
Package: linux-image (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-12-generic root=UUID=0a19dd9d-a34c-4ef8-93a2-4f859ca819c1 ro quiet splash
ProcVersionSignature: Ubuntu 2.6.31-12.41-generic
RelatedPackageVersions: linux-firmware 1.21
SourcePackage: linux-meta
Uname: Linux 2.6.31-12-generic x86_64
 (gnome-settings-daemon:1811): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1811): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:1924): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:1907): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
dmi.bios.date: 04/18/2008
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.08
dmi.board.name: 30E5
dmi.board.vendor: Quanta
dmi.board.version: 88.0A
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.08:bd04/18/2008:svnHewlett-Packard:pnHPPaviliontx2000NotebookPC:pvrRev1:rvnQuanta:rn30E5:rvr88.0A:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion tx2000 Notebook PC
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard

** Affects: linux-meta (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: amd64 apport-bug

hid-ids.h is not included - Needed
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to linux-meta in ubuntu.

More information about the kernel-bugs mailing list