[Bug 88530] Re: USB ports: connect-debounce failed, port disabled

Luminary Crush jaherring at usa.net
Tue Nov 10 16:21:28 UTC 2009


This bug has existed a long time - I noticed it about five years ago.

I have an ASUS Digimatrix HTPC (for MythTV) which has 4xUSB in the front
panel and 4xUSB in the back.  They are two different controller.  I am
running Fedora 11 now, but this started way back in Fedora 5.

When I plug my Interlink Versapoint wireless keyboard interface into the
rear controller I get the following errors:

Nov 10 08:15:20 mythtv2 kernel: usb 4-1: USB disconnect, address 2
Nov 10 08:15:29 mythtv2 kernel: hub 2-0:1.0: connect-debounce failed, port 3 disabled
Nov 10 08:15:31 mythtv2 kernel: hub 2-0:1.0: connect-debounce failed, port 3 disabled
Nov 10 08:15:33 mythtv2 kernel: hub 2-0:1.0: connect-debounce failed, port 3 disabled
Nov 10 08:15:34 mythtv2 kernel: hub 2-0:1.0: connect-debounce failed, port 3 disabled

When I plug it into the front panel controller it works fine:

Nov 10 08:15:53 mythtv2 kernel: input: Link keybd as /devices/pci0000:00/0000:00:03.1/usb4/4-1/4-1:1.1/input/input9
Nov 10 08:15:53 mythtv2 kernel: generic-usb 0003:04DF:0020.0006: input,hiddev96,hidraw3: USB HID v1.10 Mouse [Link keybd] on usb-0000:00:03.1-1/input1


[root at mythtv2 ~]# uname -a
Linux mythtv2 2.6.30.9-96.fc11.i686.PAE #1 SMP Tue Nov 3 23:41:33 EST 2009 i686 i686 i386 GNU/Linux

Bus 002 Device 003: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 1043:80fc iCreate Technologies Corp. 
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 003: ID 04df:0020 Interlink Electronics 
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 003: ID 0430:0005 Sun Microsystems, Inc. Type 6 Keyboard
Bus 003 Device 002: ID 046d:c001 Logitech, Inc. N48/M-BB48 [FirstMouse Plus]
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


The annoying thing is that for my HTPC the cable has to come out of the front and dangle in front of everything for this to work but hey, no big deal.  However, because I have a situation in which changing ports fixed the problem perhaps this can help with debugging it.

Because the Digimatrix is such a nice box I picked up a refurb on Ebay
cheap and replicated my setup for another location.  I have the same
issues - so I know it's not a random piece of hardware as I can
duplicate it two places.

I have an extra partition and am willing to try to install Ubuntu 9.10
to see if this makes a difference if you think that will help
troubleshoot.

Thanks,
Jason

-- 
USB ports: connect-debounce failed, port disabled
https://bugs.launchpad.net/bugs/88530
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to Linux.




More information about the kernel-bugs mailing list