[Bug 88746] Re: ehci_hcd module causes I/O errors in USB 2.0 devices

chad chadjensenster at gmail.com
Tue Mar 31 12:11:28 UTC 2009

I experienced this bug as well. I tried all the fixes in this thread as
well as other sites but nothing worked. Sometimes my usb would die and
lose all power and a restart wouldn't even bring back power. I could
unplug and replug in my flash drive and it would be assigned a new
address or I would have to totally shut down and reboot to reset my usb
system. That made me think that the kernel was making my usb system
crash at the bios level. I disabled my usb 2.0 in bios and it worked but
I had usb 1 transfer speeds. So I disabled bios legacy support and re-
enabled bios 2.0 on chip contoller. It again caused my usb to crash on
large files and caused a slow down in transfers on small files. I read
about plug and play crashing the usb on another thread
(http://marc.info/?l=linux-usb-devel&m=106789579416232&w=2) and looked
in my plug and play configurations in my bios. There was a option to
assign irq to usb that was enabled. I disabled it and now have had no
problems with transferring files. I think some people with this problem
might be helped by this fix.

I have award bios (not sure the version) and am running ubuntu 8.04.1
fully patched


ehci_hcd module causes I/O errors in USB 2.0 devices
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to Linux.

More information about the kernel-bugs mailing list