[Bug 67256] Re: Failure to mount root filesystem, cause unknown

ritterkeks tobias.dussmann at gmail.com
Sun Jan 11 14:33:32 UTC 2009

when my newly installed linux mint refused to boot most times and dropped to initramfs-shell i tried every solution i found, like rebuilding initramfs, etc. 
but nothing worked. 

now i found the solution for me:
i changed back the kernel parameters in grub's menu.lst.
i think, i switched the root= parameter from UUID=x to /dev/sda1 some time ago (stupid suggestion found in a wiki)
and it had not caused any errors until the kernel wouldn't find the root device anymore. 
setting the root device back to an "UUID=x" entry in the default kernel options in /boot/grub/menu.lst and "sudo update-grub" made my pc booting flawless again!
(to get the UUID of your device us "sudo blkid")

just if this same thing happend to anyone out there..

Failure to mount root filesystem, cause unknown
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to initramfs-tools in ubuntu.

More information about the kernel-bugs mailing list