[Bug 268502] Re: Bluetooth doesn't work (hci_cmd_task: hci0 command tx timeout)

Jamie Lokier jamie at shareable.org
Tue Feb 24 21:48:22 UTC 2009

Richard Hamnett wrote:
> Can you confirm that you can / cannot send a file from your mobile
> device to the laptop?

I never send files over Bluetooth between phone and laptop, and don't
know how to it.

I just tried it now, with the patched kernel, and these things happened:

   - When I asked the phone to "send by bluetooth" a picture file,
     it searched for devices and couldn't see my laptop, even though I
     set the laptop to be visible in the GNOME Bluetooth Preferences.

   - When in GNOME Bluetooth Preferences I told it to search for a new
     device to connect to, it couldn't see the phone even though I set the
     phone to be visible.

   - The laptop does have the phone in its list of known devices, so
     when I clicked button in GNOME Bluetooth Preferences to connect
     explicitly, the button grayed out, but the status icon still
     didn't show it connected after several seconds.

   - Despite the above "not connecting properly as shown by GNOME",
     when I ran pand on the laptop, it *was* able to make a 3G data
     connection to the internet through the phone!

   - Even though the phone was connected and had 3G networking going
     on, and the phone's screen showed a connected icon, the phone
     _still_ didn't show the laptop in the list of devices to send
     files to.

I'm guessing the laptop isn't advertising its ability to receive
files.  Since I never use this part of Bluetooth, and there's no
option for it in GNOME Bluetooth Preferences (they removed it!),
I don't know if this has anything to do with the kernel changes.

All I know which works is 3g data networking - running "pand" on the
laptop, that pairing with the phone, and the resulting BNEP network
able to be used as an internet connection.  (Btw, it's annoying that
"pand" isn't in the new bluez packages at all... and the scripts on
bluez.org using D-BUS to connect don't work with the new version
of bluez...  a different bug).

It's possible that sending and receiving files is not connected with
the kernel change at all, since I noticed some people are reporting
bugs with that and responses say it's something to do with the OBEX
server, not pairing.

As I don't use this part of Bluetooth at all, I'm not interested in
fiddling about with OBEX except just trying it for you now :-)

-- Jamie

Bluetooth doesn't work (hci_cmd_task: hci0 command tx timeout)
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to Linux.

More information about the kernel-bugs mailing list