[Bug 272247] Re: System freezes during boot, unless I hold a key down

Mehall mehall at mehall.co.cc
Sun Apr 12 01:13:36 UTC 2009

Hey all, i was looking at smaller ones that were dupes of this, just
found this.

It seems to be upstream, since I've had issues in other distros also.

Here's what I have tried:

Copied the debug instructions from wiki, added own comments: (it's all
fairly clear)

Try booting with the "acpi=off" kernel parameter
This will disable ACPI support. If the error is the same with acpi enabled and disabled, this may not be an ACPI issue.
If "acpi=off" allows the system to boot, try to isolate the ACPI issue with the following boot parameters

Did that, boots fine then

Try booting with "acpi=ht"
This disables all of ACPI except just enough to enable Hyper Threading. If acpi=off works and acpi=ht fails, then the issue is in the ACPI table parsing code itself, or perhaps the SMP code.
Try booting with "pci=noacpi"
This disables ACPI for IRQ routing and PCI scanning.
Try booting with "acpi=noirq"
This disables ACPI for IRQ routing.

All the above make it boot fine.

Try booting with "pnpacpi=off"
This disables the ACPI component of the Linux Plug and Play code.
Try booting with "noapic"
Disables the IO-APIC for IRQ routing or PCI scanning.

Those two options make it boot, but same as original bug, need to press
keys to force it to boot.

Try booting with "nolapic"
Disables the local APIC

Boot fails at:

"ata3: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata3.00:qc timeout (cmd 0xec)
ata3.00: failed to IDENTIFY (I/O erroor, err_mask=0x4)"

that's the main thing, then it says "Gave up waiting for root device"
and then lists common issues, etc.

Drops to Busybox.

hardware: HP G6062ea, Atheros Wifi, nVidia 7000m nForce 610m, AMD Athlon X2 64 TK-57 1.9GHz

Didn't happen in older kernels, not tried Jaunty yet.

** Description changed:

  Once the Ubuntu splash screen loads with the progress bar that moves back and forth, it freezes. Holding down any key unfreezes the system, and it continues 
  loading normally, until I release the key, at which point it freezes again. Holding a key down again unfreezes the system again.
  Pressing Alt+F1 to show the output also freezes, so I know it isn't just
  the splash screen freezing, but the entire system.
  Once X loads, it works perfectly fine though, and I don't have to keep
  holding a key down.
  Update : This bug happens with 2.6.26 and 2.6.27 kernels with a computer
  that has Nvidia MCP67 motherboard. A known workaround that sometimes
  works is to add nolapic to GRUB boot kernel options. acpi=noirq is also
  known to work.
  ProblemType: Bug
  Architecture: amd64
  DistroRelease: Ubuntu 8.10
  NonfreeKernelModules: wl nvidia
  Package: usplash 0.5.23
  SourcePackage: usplash
  Uname: Linux 2.6.27-3-generic x86_64
  Possible systems affected include:
  Nvidia MCP67 Chipset
  Compaq Presario F700
  Compaq Presario F763NR
  Sony Vaio PCG-GRT-815E - from the Mandriva errata
  HP Pavilion DV6545eg Notebook - from duplicate
  HP Pavilion DV6736nr
  HP Pavilion DV6745us - from a duplicate
  HP Pavilion DV6620es
  HP Pavilion DV9610us
  HP Pavilion DV9700z
  HP Pavilion DV6915nr
  HP Pavilion DV9645ed
+ HP G6062ea

System freezes during boot, unless I hold a key down
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to Linux.

More information about the kernel-bugs mailing list