[Bug 290885] Re: SRU: Backport of Boot Degraded RAID functionality from Intrepid to Hardy

Bill Smith bsmith1051 at yahoo.com
Thu Nov 6 00:07:12 UTC 2008

OK, so the test seemed to go ok (aside from my BIOS trying to boot from
my 'data' drives).

- As you suggested I ran the update command on just the boot array,
 > sudo grub-install /dev/md0
  It correctly identified the two physical drives and updated them both
- The initial boot (still both drives) was fine.  But then it hung on shutdown?  
  Tried another boot-and-shutdown and this time it shutdown ok.
- 1st test boot (with drive #2 removed).  There was the expected 2-min delay
  before prompting to boot degraded.  The prompt timed-out before I could finish
  reading the screen so I unintentionally did the "Answer no" test?
  Rebooted, waited, then entered Yes and it booted normally.
- 2nd test boot (with drive #1 removed). Same behavior as previous test.
- 3rd test boot (both drives reconnected). Booted on drive #1 and was able to use
  'mdadm --add' command(s) to restore both arrays successfully.

- is there a way to simplify the message screen?  Maybe add section headers so that
  you can immediately see what each section is about.
- does the prompt need to have a timer?
- is there a single command that could be entered at the Busybox prompt to 
  manually initiate the proper boot-as-degraded script?  If so, can the system display it after
  you select 'No' (or time-out) ?
- why doesn't Partition Editor (Gparted) recognize 'md' devices?  Probably unrelated to this backport
  but you seem like the person to ask!  On this 8.04.1+ system my Gparted v0.3.5 says,
  "kernel is unable to re-read the partitiontables on /dev/md0"
  If you're not supposed to use Gparted to edit raid devices, it would be nice if it directly told you so
  and maybe offered to let you view them in read-only mode.
- There's a typo in one of the modules.  When I shutdown I saw a command-line message,
  "Network Manager: caught terminiation"

Finally, after I ran these tests (yesterday and today), I was prompted by Update Manager that there was another update for 'initramfs-tools' and 'mdadm' -- was that from you?  I didn't want to install them until I knew they weren't a wrong version.  They didn't have any Description or Version info in Update Manager, but Synaptic identified them:
- initiramfs 0.85eubuntu39.3~ppa4
- mdadm 2.6.3+200709292116+4450e59-3ubuntu4~ppa4

Are they new updates that you want me to re-run the test with, after
downloading them?

SRU: Backport of Boot Degraded RAID functionality from Intrepid to Hardy
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to initramfs-tools in ubuntu.

More information about the kernel-bugs mailing list