[Bug 228375] [NEW] ACPI Power Switching Fails Toshiba L30

danwood76 danwood76 at gmail.com
Thu May 8 21:09:00 UTC 2008

Public bug reported:

Binary package hint: linux-image

First problem is that the laptop will neither startup nor shutdown
without being plugged into AC power.

Second issue is that when the AC is removed whilst in Ubuntu the kernel
does an Oops (attatched).

The ACPI worked fine in Gutsy, so far I have tried compiling a vanilla
2.6.24 which gave the same results, then tried the latest 2.6.26-rc1,
this was marginally better but still gave an oops. (2.6.26-rc1 would
start but not shutdown correctly)

Current Kernel Version:
Linux danny-laptop 2.6.24-17-generic #1 SMP Thu May 1 14:31:33 UTC 2008 i686 GNU/Linux

This was an issue with the default hardy kernel, 2.6.24-17, Vanilla 2.6.24, Vanilla 2.6.26-rc1.
Im going to recompile the 2.6.23 kernel to see if the ACPI works again on that version.

Please inform me if anymore information is required.

** Affects: linux-meta (Ubuntu)
     Importance: Undecided
         Status: New

ACPI Power Switching Fails Toshiba L30
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to linux-meta in ubuntu.

More information about the kernel-bugs mailing list