[Bug 37370] Re: Crash/freeze when restarting networking, rt2570 wireless USB (DWL-G122, rev B1)

FSHero minesh.fshero.mistry at googlemail.com
Thu Jun 26 18:11:20 UTC 2008

Hello, I know that the bug is closed, but I think I still have the bug
in Hardy. (at least the symptoms I am experiencing are very similar to
what is described.)

I have a Medion 8383XL PC which comes with a Ralink card which used to
work fine in Kubuntu Feisty (7.04), with the rt2570 driver (I believe it
was). I could use the kde systemsettings -> Network settings to enter my
WEP key.

Now, I compiled a cvs serialmonkey driver in Kubuntu Hardy (8.04) (the
folder name on my computer is rt2570-cvs-2008062414). Now, when I go to
the kde systemsettings, the keyboard alone freezes. I can still do
things with the mouse. I can shut down or restart, but it sort-of
hangs... but because my power button is assigned to "shut down", I can
press it to shut down cleanly. As far as I can remember, this occurs
also if I do "sudo /etc/init.d/networking restart". I have configured my
card through the file /etc/networking.d/interfaces. To be honest, I
haven't tried it much -- I tried to connect with both WEP and WPA
yesterday, but no luck... I could not obtain an IP address from my

I could get WEP working with a cvs driver from serialmonkey -- the
folder which the .tar.gz extracted to was called rt2570-cvs-2008060113.

I was wondering if anyone needs more info, as I would be happy to
provide. Also is there a workaround for this?

Crash/freeze when restarting networking, rt2570 wireless USB (DWL-G122, rev B1)
You received this bug notification because you are a member of Kernel
Bugs, which is a direct subscriber.

More information about the kernel-bugs mailing list