[Bug 81012] Re: Ubuntu 6.06 does not properly recognize serial to usb modem

ramnarayan ramnarayan.k at gmail.com
Thu Jun 26 10:11:45 UTC 2008


First sorry for the delayed reply

But the Serial to USB modem works under 7.04 and 7.10 (i think) but
definitely not under 8.04 (hardy). So am reopening the bug.

Ok how it works under 7.04 is that i have been making a rules file under

/etc/udev/rules.d

the file is called
026_ti_usb_3410.rules

with the following contents
#TI USB 3410

SUBSYSTEM=="usb_device" ACTION=="add"
SYSFS{idVendor}=="0451",SYSFS{idProduct}=="3410" \

SYSFS{bNumConfigurations}=="2" \

SYSFS{bConfigurationValue}=="1" \

RUN+="/bin/sh -c 'echo 2 > /sys%p/device/bConfigurationValue'"

***
doing this make the OS attach the serial to USB modem to /dev/ttyusb0 and my wvdial work.

I upgraded to 7.10 and this continued to work

but i tried to make the same work under 8.04  and  this same process
does not work. Am not sure if its an 8.04 problem only or if a tweak is
required somewhere.

my wvdial file looks like this
[Dialer Defaults]

[Dialer 92]
Modem = /dev/ttyUSB0
Baud = 230400
Phone = #777
Init1 = ATZ
Stupid Mode = 1
Dial Command = ATDT
Username = XXXX
Password = xxxxx
PPPD Options = crtcts multilink usepeerdns lock defaultroute

****
So right now i am back at 7.04 and accessing the internet on the FWT

thanks
ram


** Changed in: linux-source-2.6.15 (Ubuntu)
       Status: Invalid => New

-- 
Ubuntu 6.06 does not properly recognize serial to usb modem
https://bugs.launchpad.net/bugs/81012
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to linux-source-2.6.15 in ubuntu.




More information about the kernel-bugs mailing list