[Bug 236932] Re: Bug in upgrade 2.6.24-17-31-generic for UBUNTU 8.04

Szabó András szabo.a.a.g at gmail.com
Mon Jun 9 17:39:22 UTC 2008


*** This bug is a duplicate of bug 236021 ***
    https://bugs.launchpad.net/bugs/236021

Bug in upgrade to 2.6.24-17-generic & to 2.6.24-18-generic in  UBUNTU
8.04

Hi everybody,

Long time nobody answered this problem up to now.
First of all, thanks for the comments!

Finally, I started both kernel versions in recovery mode and I could
find out the reason of the problem without finding the solution.

There were in both cases the same failure report:

Begin: Running /scripts/local-premount
mount: Mounting /dev/disk/by-uuid/9068-E8C6
	   on /root failed: no such device
mount: Mounting /root on /host failed: invalid argument
ALERT! /host/ubuntu/disks/root.disk does not exists.
	  Dropping to a shell!

BusyBox v1.1.3 (Debian 1:1.1.3-5ubuntu12) Built-in shell (ash)
 Enter 'help' for a list of built-in commands.
 (initramfs)

When checked the HDD D:\ partition under Windows or 
under Ubuntu (running in grub the kernel 2.6.24.16-generic
instead of the two unoperable ones of 17 and 18 gen.)
I found there the ubuntu and all the claimed subdirectories 
and the disks that were not found by the 17 and18 kernels.

Possibly, during the upgrade with dpkg one of the configuration 
files were wrong due to a bug and when started the 'ash' shell it 
could not work and react to any command because of the missing 
necessary 'background' virtual disk contents. This is why the
BusyBox did not give a correct response and I could not achieve to exit.

What can be and where to find the wrong script or configuration file to repair.
Maybe, one of you give me the answer, but I am unable to correct
the corresponding init.rd file if it is the responsible.

I tried to correct the problem writing into the terminal the followings:

	sudo dpkg --clear-avail && sudo apt-get update
and
	sudo dpkg --configure -a

Nothing happened.

In the /boot/grub/menu.lst I found:

title		Ubuntu 8.04, kernel 2.6.24-17-generic
root		(hd0,4)/ubuntu/disks
kernel		/boot/vmlinuz-2.6.24-17-generic root=UUID=9068-E8C6 loop=/ubuntu/disks/root.disk ro single
initrd		/boot/initrd.img-2.6.24-17-generic

title		Ubuntu 8.04, kernel 2.6.24-16-generic
root		(hd0,4)/ubuntu/disks
kernel		/boot/vmlinuz-2.6.24-16-generic root=UUID=9068-E8C6 loop=/ubuntu/disks/root.disk ro quiet splash
initrd		/boot/initrd.img-2.6.24-16-generic

The above is the same in case of kernel 2.6.24-18-generic.

Maybe somebody corrects the problem and this short 
description of the failure report will help to find the bad spot.

Thanks again and, until the problem has been solved i am using
the kernel 2.6.24-16-generic.

By the way! Can I delete the useless parts and files installed
and how?

András Szabó

-- 
Bug in upgrade 2.6.24-17-31-generic for UBUNTU 8.04
https://bugs.launchpad.net/bugs/236932
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to initramfs-tools in ubuntu.




More information about the kernel-bugs mailing list