[Bug 251481] [NEW] linux-xen metapackage Hates Freedom.

Nick Moffitt nick at canonical.com
Thu Jul 24 12:46:48 UTC 2008


Public bug reported:

Binary package hint: linux-xen

Submitted from Hardy 8.04.1 as of 24 July 2008:

Exhibit A:
	Package: linux-xen
	Section: universe/metapackages
	Source: linux-meta
	Depends: linux-image-xen (= 2.6.24.19.21), linux-restricted-modules-xen (= 2.6.24.19.21)

Exhibit B:
	Package: linux-restricted-modules-xen
	Section: multiverse/metapackages
	Source: linux-meta
	Version: 2.6.24.19.21

Addendum:
	Package: ubuntu-xen-server
	Section: universe/base
	Source: xen-meta
	Depends: bridge-utils, libc6-xen, libxen3, linux-xen, python-xen-3.2, xen-docs-3.2, xen-hypervisor-3.2, xen-tools, xen-utils-3.2

So ubuntu-xen-server is in Universe, but is uninstallable unless you add
multiverse sources.  Likewise the linux-xen package.

It is my understanding that packages in universe must not depend on
multiverse, so perhaps ubuntu-xen-server should depend on linux-image-
xen and linux-xen should be itself moved to multiverse.  Or maybe some
of this ought to be moved into Recommends or something.

** Affects: linux-meta (Ubuntu)
     Importance: Undecided
         Status: New

-- 
linux-xen metapackage Hates Freedom.
https://bugs.launchpad.net/bugs/251481
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to linux-meta in ubuntu.




More information about the kernel-bugs mailing list