[Bug 61235] Re: USB mass storage stops working after a while

alonso honkkis at gmail.com
Sun Jan 20 14:01:28 UTC 2008

I would like to add that I had similar problem with USB HD through
kernels 2.6.18-2.6.22 using the combination of Lacie USB 500 GB HD and
VIA VT6212L USB chip in an old PIII 500 Mhz machine using debian 4.0
(also tried ubuntu live CDs for gutsy and hardy to no avail)

USB 2.0 Device: Lacie black desktop USB 500 GB hard disk

Jan 20 15:27:43 localhost kernel:   Vendor: ST350083  Model: 0AS

us 001 Device 002: ID 059f:1010 LaCie, Ltd
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0        64
  idVendor           0x059f LaCie, Ltd
  idProduct          0x1010
  bcdDevice           c6.83
  iManufacturer           2 LaCie
  iProduct                3
  iSerial                 1 ST3500830A            9QG616JN
  bNumConfigurations      1

USB Host is prodige USB 2.0 pci-card with VIA VT6212L chip:

00:10.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 65) (prog-if 20 [EHCI])
        Subsystem: VIA Technologies, Inc. USB 2.0
        Flags: bus master, medium devsel, latency 66, IRQ 11
        Memory at 42000000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [80] Power Management version 2

Very old Compaq deskpro PIII 500 Mhz computer

I tried everything suggested in


What helped me was the combination of 1 and 2: 

1. following patch to /drivers/usb/storage/unusual_devs.h
(found this solution in 

UNUSUAL_DEV(  0x059f, 0x1010, 0x0000, 0x0000,
        "USB to IDE Disk",

2. in ehci-hcd.c:

#define EHCI_TUNE_CERR          0       /* 0-3 qtd retries; 0 == don't
stop */

I still see occasional high speed usb device resets, but so far no
disconnects. There is definitely something strange going on with this
setup, but I'm happy to have solved it. Also the transfer rate is pretty
ok, for such an old machine:

hdparm -t /dev/sda

 Timing buffered disk reads:   88 MB in  3.03 seconds =  29.01 MB/sec

USB mass storage stops working after a while
You received this bug notification because you are a member of Kernel
Bugs, which is a subscriber of a duplicate bug.

More information about the kernel-bugs mailing list