[Bug 62576] Re: Dapper instalation freezes at 15% on sony vaio vgn-s5hp

kernst kernst at one.net
Fri Feb 29 21:56:22 UTC 2008

Hi, all. I can confirm that the problem described (at least the
manifestation I experienced) is still an issue with the 7.10 x86
standard graphical installer, which I downloaded on 2/28/2008. I ran
into the problem on a system with a *desktop* computer with multiple
hard disks, all containing preexisting filesystems, all of which were
mounted when I originally tried to run the installer. I documented
everything I did to get the installer to progress past 15% here:

Many related bugs (#112828, #113237, #67723) suggest kernel problems,
but I actually found partman and/or ubiquity to be the likely culprit in
my case, specifically /lib/partman/commit.d/01unmount_busy, which I had
to kill (after unmounting all filesystems) in order to get the installer
to continue. The installer *did*, however, pick back up essentially
where it left off and completed without another hitch. What I'm not sure
of is whether partman's "busy" script is hanging because ubiquity didn't
do a good enough job of prompting the user and/or unmounting partitions
before launching partman, or whether there's something wrong with the
script causing it to hang in some circumstances.

What tipped me off about '01unmount_busy' was the fact that it was
consuming over 60% of the CPU, presumably waiting for the partition I
was installing to (which was mounted at the time) to become free. I
didn't really have the opportunity to digest what was going on inside
the script, but it was definitely solely responsible for the lockup at
15% in my case.

Dapper instalation freezes at 15% on sony vaio vgn-s5hp
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to linux-source-2.6.15 in ubuntu.

More information about the kernel-bugs mailing list