[Bug 134660] Re: Ralink rt2400 / rt2500 / rt2570 / rt61 / rt73 do not work out of the box in Gutsy/Hardy

Boden Larson boden.larson at gmail.com
Fri Feb 15 21:24:17 UTC 2008

I would also like to chime in with a complaint that the rt2500 series
drivers don't work correctly in Gutsy (2.6.22-14-generic), at least not
with WPA.  I'm using a Linksys WUSB56G v4 adapter.

I compiled the rt2570 legacy driver from serialmonkey and installed it.
With this driver I was able to get a connection using WPA, but *only*
from the command line using iwpriv or the rutilt program.  This had me
hopeful, except that DHCP will not work.  If I manually configure my IP
settings on rausb0, I can talk on the WPA network just fine.  I tried
both various mixtures of dhcpcd and dhclient to no avail.  Requests
timed out.

Uninstalled NetworkManager and installed wicd.  This did not help at
all.  The rt2570 driver and wpa_supplicant do not jive using wext or
ralink legacy (or any other driver).

I tried wifi radar.  Again, no WPA.

Can't compile new rt2x00 drivers from serialmonkey against this kernel
so I can't try those.

The only "solution" to this problem for me has been to use ndiswrapper
with the Windows drivers for this adapter.  This works well with WPA,
and I can roam from network to network just fine.  The problem with this
solution is that there is no way to use advanced features like monitor
mode.  I use kismet when setting up access points, for example.  When I
need to use kismet I have to remove ndiswrapper and then I use the
rt2500usb driver from Gutsy which doesn't work for connecting, but can
sniff just fine.  This is a bit of a pain in the rear, especially since
these all of these ralink drivers have a tendency to lock my keyboard up
when I remove them with modprobe, so I have to restart with the mouse.
Thus I can switch from ndiswrapper to rt2500usb, but I can't switch back
without restarting.


Ralink rt2400 / rt2500 / rt2570 / rt61 / rt73 do not work out of the box in Gutsy/Hardy
You received this bug notification because you are a member of Kernel
Bugs, which is a subscriber of a duplicate bug.

More information about the kernel-bugs mailing list